Admin Menu Editor
[resolved] plugin admin page broken (when cfrom enabled, jquery conflict ?) (5 posts)

  1. reghyz
    Posted 5 years ago #


    When I activate cforms II plugin, all menu blocks (blocks blue) are disappearing from the admin page of AdminMenuEditor (but I still have top icons and buttons save/ undo/load default, and i keep my menu modifications). if I disable cforms everything is back to normal.

    Safari's Inspector give me the following errors:

    ReferenceError: Can't find variable: jQuery  - load-scripts.php:17
    TypeError: Result of expression 'd.widget' [undefined] is not a function. -load-scripts.php:24
    TypeError: Result of expression 'menuBox.sortable' [undefined] is not a function. menu-editor.js:459

    it looks like there's a jquery conflict somewhere , no ?

    If i disable Cform II this alerts are disapearing.

    I've tried loading jquery latest version in my theme's function.php with :

    ("http://ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js"), false, '');

    and the the error is apearing again (even with cform disabled)
    are you using the last jquery version ?

    I have these plugins enabled:

    Admin Menu Editor 1.1.3
    Advanced Custom Fields 2.0.5
    AJAX Thumbnail Rebuild 1.05
    Category Checklist Tree 1.1
    cforms 12.1
    Custom Taxonomy Columns 1.0
    TinyMCE Advanced

    has anyone encountered the same problem or have an idea about what's going on?

    (Another thing, if I disable and reenable the plugin are my changes will be applied on the menu again, or should I redo everything? I'm scared to disable it for testing)

    thanks :)
    (sorry for my english )


  2. reghyz
    Posted 5 years ago #

    Hi ,

    after many tests i think i've just found a solution to this issue (and maybe others jquery compatibilities issues in the admin) by turning off WP javascript concatenation :

    Disable Javascript Concatenation
    To result in a faster administration area, all Javascript files are concatenated into one URL. If Javascript is failing to work in your administration area, you can try disabling this feature :

    define('CONCATENATE_SCRIPTS', false);

    (add this line in your wp-config.php )


    this doesn't correct the issue at the root but, at least, it seems to works.
    (duno yet if there's any sides effects)

    I hope this will help to find the real problem origin.

  3. murrydan
    Posted 4 years ago #

    Wow, that worked for me.. THANKS!!!

  4. pettedemon
    Posted 4 years ago #

    Works for me!!

  5. Con Schneider
    Posted 4 years ago #

    Hi reghyz,

    Thank you very much for the tip. That did made my situation a whole lot better. The only thing that is still broken is the toggle button which expands and collapses menus. Everything else (drag and drop etc.) is finally working again. Yay!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic