Support » Plugin: Admin Menu Editor » [Plugin: Admin Menu Editor] I hide "Menu Editor" by mistake.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Janis Elsts

    (@whiteshadow)

    Unless you’ve also changed the “Required capability”, you should still be able to access the editor by going directly to its admin URL:

    http://yoursitehere.com/wp-admin/options-general.php?page=menu_editor

    The “Hide” button makes a menu invisible, but doesn’t prevent those who known the URL from loading the page. If you want to actually restrict menu access, you need to use the capability field.

    Oh boy, I did this by accident, too. I think I hid “Settings” so now I can’t get to this. Going directly doesn’t work, because the parent (“Settings”) is no longer accessible. I’m guessing I’ll have to just remove the plugin… but would prefer to keep using it. Seems like hiding this should not be allowed!

    Hey, found the solution on another thread.

    Go to http://yoursitehere.com/wp-admin/?reset_admin_menu=1

    Go to http://yoursitehere.com/wp-admin/?reset_admin_menu=1

    Had to log in ( which I almost never do ) to say THANK YOU !!

    This should be obviously documented somewhere.

    Again, relish1227, Thank You from the bottom of my several hours worth frustrated heart !!

    Plugin Author Janis Elsts

    (@whiteshadow)

    This *is* documented on the plugins page (scroll down to the “Notes” section):
    http://wordpress.org/extend/plugins/admin-menu-editor/

    I accidentally locked myself out of the Settings section. I can deactivate the plugin, but would prefer not to. I visited the http://yoursite.com/wp-admin/?reset_admin_menu=1 (as instructed above) and got a “403 Forbidden” message:

    Forbidden
    You don’t have permission to access /wp-admin/ on this server.

    Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.

    Any thoughts?

    Plugin Author Janis Elsts

    (@whiteshadow)

    That URL is just an example; you’re supposed to replace “yoursite.com” with your own site. Does it still give you a 403 error if you do that? Or have I misunderstood you and the error was on your site?

    I still got the error even with my own domain. I guess I should have said that above. Thanks for your reply.

    Adam: Hmm, not sure, but maybe there is some sort of permissions issue going on for you on your server? When I google “You don’t have permission to access /wp-admin/ on this server.” there are a lot of results — maybe worth checking that angle. Just seems like it could be a separate issue from the Menu Editor plugin.

    Curt44319: Glad it helped!

    I don’t exactly know what it was, but here was some setting in my htacces that was causing this. I removed the htaccess code temporarily so that I could reset the Admin Menu Editor plugin, and now everything’s working fine. Thanks, relish1227, for your help.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Plugin: Admin Menu Editor] I hide "Menu Editor" by mistake.’ is closed to new replies.