WordPress.org

Forums

Share Buttons by AddToAny
[resolved] [Plugin: AddToAny: Share/Bookmark/Email Buttons] Drop Down Menu is Gone (13 posts)

  1. genesteinberg
    Member
    Posted 4 years ago #

    The last two versions, including the current .9.9.9.2 have been useless to me. Even with default settings, there's no drop-down menu when you click on the link in your blog. It just switches you to a large page where you see zillions of social networking icons.

    Obviously something is wrong, but previous versions worked fine, which is why I have decided not to upgrade, at least for now.

    Am I alone in this dilemma?

    Peace,
    Gene

    http://wordpress.org/extend/plugins/add-to-any/

  2. micropat
    Member
    Plugin Author

    Posted 4 years ago #

    Have you tried switching to the default Twenty Ten theme to see if it's a problem with your current theme?

    See "Why isn't the drop-down menu appearing?" in the FAQ for details on how to fix your theme if your theme is coded improperly.

  3. genesteinberg
    Member
    Posted 4 years ago #

    It worked fine until the last two versions of your plugin. So unless you did something to suddenly break a theme where it previously worked, your suggestion would not apply.

    Peace,
    Gene

  4. micropat
    Member
    Plugin Author

    Posted 4 years ago #

    Gene, the last two versions utilize a required template tag (wp_footer). If your theme doesn't have this required template tag, you'll need to consult your theme author or apply the [relatively simple] fix yourself. Do try the suggestion in my previous post.

  5. genesteinberg
    Member
    Posted 4 years ago #

    Curious. It is there. It has always been there, which means your implication essentially accuses my theme designer of incompetence.

    In any case, I verified that the coding of the header and footer of my theme is correct in this regard. The problem still exists.

    Can I have a workable solution this time?

    Peace,
    Gene

  6. genesteinberg
    Member
    Posted 4 years ago #

    And if there are any doubts, here are the last three lines of my footer:

    <?php wp_footer(); ?>
    </body>
    </html>

    That's what's always been there, since the theme was designed several years ago, and it has withstood subsequent modifications.

    I'm back to using an older version of your plugin to get the drop-down menu.

    Any other ideas?

    Peace,
    Gene

  7. micropat
    Member
    Plugin Author

    Posted 4 years ago #

    A workable solution requires troubleshooting. You should provide the URL to your site (with the latest plugin enabled) for further troubleshooting. If it's not a theme issue (which is the most common problem for your symptom), then it's likely a conflict with another misbehaving plugin. Other plugins generating JavaScript errors or W3C invalid (X)HTML code are common conflicts.

  8. genesteinberg
    Member
    Posted 4 years ago #

    OK. I have two interrelated sites for you to check.

    This one: http://www.technightowl.com/newsletter has the new version enabled.

    This one: http://www.technightwol.com has an older version.

    Peace,
    Gene

  9. genesteinberg
    Member
    Posted 4 years ago #

    make that http://www.technightowl.com for the main site. Too bad we can't edit errors in our posts. :)

    Peace,
    Gene

  10. micropat
    Member
    Plugin Author

    Posted 4 years ago #

    So you have validation errors, but what seems to be primarily affecting AddToAny is the improperly closed HTML comments on your pages:
    <!-- 18 queries. 0.248 seconds. —>
    <!-- Eof 'footer' —>

    It should instead look like:
    <!-- 18 queries. 0.248 seconds. -->
    <!-- Eof 'footer' -->

    The bugs are either hardcoded in your theme or another plugin is mangling your theme's output.

  11. genesteinberg
    Member
    Posted 4 years ago #

    Simpler. Autocorrect turning two hyphens to a dash. Simple to fix and not a serious issue. Try now.

    Peace,
    Gene

  12. micropat
    Member
    Plugin Author

    Posted 4 years ago #

    Issue resolved. The drop-down menu is back in action since you fixed the dash issue with your HTML comments. It might be helpful to others if you post in detail how autocorrect affected you. Were you using the WordPress Theme Editor or something else?

  13. genesteinberg
    Member
    Posted 4 years ago #

    Simple text editing of a theme in an OS that does auto correct (such as Mac OS X Snow Leopard, configured in Language & Text preference pane). You type two hyphens, and it autocorrects and converts it to a dash. Very innocent, and not readily obvious unless you look for it. :)

    Peace,
    Gene

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Share Buttons by AddToAny
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags