WordPress.org

Forums

Share Buttons by AddToAny
[Plugin: AddToAny: Share/Bookmark/Email Buttons] Default URL Address (6 posts)

  1. silkphoenix
    Member
    Posted 3 years ago #

    Hello,

    I am new to WordPress Plug-ins, so please bear with me if my question looks stupid.

    I have already installed the AddToAny: Share/Bookmark/Email button into my Blog. But when I was doing a test, the url link is the wrong page of my blog. I would like it use my Home page url instead. How could I change it? I went to the site Help and it has the following:

    <?php if( function_exists('ADDTOANY_SHARE_SAVE_KIT') ) {
    ADDTOANY_SHARE_SAVE_KIT( array("linkname" => "Example Page", "linkurl" => "http://example.com/page.html") );
    } ?>

    Is this what I'll use to change the url link? If so, where do I add it to? I know how to get to the Settings but just don't know where should I add this template to, if that's the correct way to change my url.

    Any suggestions/comments are much appreciated.

    Thank you.

    http://wordpress.org/extend/plugins/add-to-any/

  2. silkphoenix
    Member
    Posted 3 years ago #

    I found out that the problem is my Permalink wasn't set up correctly and it has nothing to do with the AddtoAny plug-in (thank you to Pat, the developer, for telling me that the problem has nothing to do with the plug-in which allows me to look into other resources.) After I reset the Permalink in my Blog, now it's working fine.

  3. edkaded
    Member
    Posted 3 years ago #

    Hi silkphoenix,

    I seem to be having a similar issue. I have various pages and posts, however I only want to share one specific post. I added the following 2 lines under "Additional Options":

    a2a_config.linkname = "title";
    a2a_config.linkurl = "http://linkurl/?p=35";

    However, it still only uses the current page/URL when sharing, not the specified URL.

    So my questions are, how exactly did you fix your issue?
    What do you mean with your permalink was not set up correctly?
    Is my permalink not correct?
    How did you reset your permalink?

    Thanks!

  4. silkphoenix
    Member
    Posted 3 years ago #

    edkaded,

    I went to WordPress Settings (the one on the left column, towards the bottom) / Permalink and there are several options I can choose and I chose the "Day and name" one. At least that works for me. If it doesn't work for you, you can try other options. Good luck.

  5. micropat
    Member
    Plugin Author

    Posted 3 years ago #

    @edkaded you don't want those specific lines of code in Additional Options. Instead you should place the following code, for example, in your theme's file(s), so you can hard-code the button in your theme:

    <?php if( function_exists('ADDTOANY_SHARE_SAVE_KIT') ) {
        ADDTOANY_SHARE_SAVE_KIT( array("linkname" => "Example Page", "linkurl" => "http://example.com/page.html") );
    } ?>
  6. Marja Beckers
    Member
    Posted 3 years ago #

    Hi All,

    I seem to be having the same problem

    the page url I want to share are build up like this:
    http://www.searchworkx.nl/vacatures?cc=show&id=30341
    (the id nr is always different)

    The url that gets shared is:
    http://www.searchworkx.nl/vacatures

    Changing my permalinks is not an option by the way.

    IsnĀ“t there an option to share the complet current url?

    Kind regards,
    Marja

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Share Buttons by AddToAny
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags