WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: AddToAny: Share/Bookmark/Email Buttons] Add to Facebook Not working

[Resolved] [Plugin: AddToAny: Share/Bookmark/Email Buttons] Add to Facebook Not working

Viewing 14 replies - 1 through 14 (of 14 total)
  • I am having the same problem. In addition to that, the title always comes up as (No Title) instead of grabbing the post title.

    cheshmandaz
    Member

    @cheshmandaz

    Same problem here. Nobody from AddToAny or anybody else to help? Thanks

    outdooreyes
    Member

    @outdooreyes

    You are correct. Facebook worked properly with the .8 release and the .9 release and the .10 release does not work for AddToAny. The big issue is that they released .9, I believe yesterday… which I updated to all my numerous blogs… and then released .10 today… which I though would fix the Facebook problem. As an entrepreneur (retired now), who has developed many years of innovative software, this type of update release is unacceptable for such a dominant company that many websites depend on. Simple code from Facebook does not depend on AddToAny integration and I don’t believe that other than Twitter, the percentage of exposure with the many other options available from AddToAny makes that much of difference today.

    If AddToAny providers are slow or down, your website will not perform correctly and it probably will turn people away. I am considering just using the code directly from Facebook and Twitter and not have to deal with that possibility.

    Plugin Author micropat
    Participant

    @micropat

    Thanks for the reports.

    This is actually a Facebook bug that affects mostly new posts & pages – basically any page that Facebook hasn’t crawled and cached yet. We announced the issue with Facebook’s bug on Twitter here. I’ll report back when we hear more from Facebook.

    Plugin Author micropat
    Participant

    @micropat

    We just pushed out a workaround for Facebook’s sharing bug where shared URLs are malformed just as cmahaney initially reported above.

    We’re still waiting for Facebook to fix their “(No Title)” bug.

    Courtney
    Participant

    @cmahaney

    Micropat, thanks so much for the updates.

    Plugin Author micropat
    Participant

    @micropat

    Thanks for the initial report. 🙂

    AddToAny has switched over to using the AddToAny Facebook application that does not require end-user permissions for sharing. So far it’s working wonderfully. It might even be better than before!

    I m having a problem regarding the icon which gets attached to the FB post. in the older version i could select what I wanted, now it automatically selects the Soundcloud icon! Please help!

    outdooreyes
    Member

    @outdooreyes

    There is another problem (similar to the jakechec post above). It does not give you a choice of images and it selects only 1… the incorrect image.

    yessss that is what i was referring to 😛

    Plugin Author micropat
    Participant

    @micropat

    Facebook reported that they had it fixed Thursday evening. After monitoring their endpoint for a while, we’ve reverted back to Facebook’s native sharing mathod.

    Thumbnail selection is back!

    Fanaticweb
    Member

    @fanaticweb

    Hi there, I noticed something lately also within the topic of the thumbnails, when users click the Like FB button, the thumbnail pulled is not even the one attached to the post.
    I’m using a theme with Custom posts, the thumbnail that was attached in the post was uploaded by the end user, meanwhile, when hitting the FB like button, the thumbnail is randomly pulled from the gallery of another active plugin (DataFeeder random Ads V3), is there a know conflict with this plugin or is this behavior related to the above discussion?
    For the record, this issue does not occur if we opt to Publish the post on FB, its just the Like button that is acting that way, had to disable it in the meantime.

    hoagvision
    Member

    @hoagvision

    I am also unable to choose any thumbnail used in respective post, acting very strange with what it chooses. Any help?

    Plugin Author micropat
    Participant

    @micropat

    Facebook Like doesn’t accept values from AddToAny. Instead, Facebook scrapes your page for these details.

    You’ll need to adjust your theme for thumbnail & description issues. Troubleshooting with Facebook’s tool will give you a lot of insight into how Facebook is reading your pages:
    http://developers.facebook.com/tools/lint/

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Resolved] [Plugin: AddToAny: Share/Bookmark/Email Buttons] Add to Facebook Not working’ is closed to new replies.