Support » Plugin: AddToAny Share Buttons » [Plugin: AddToAny: Share/Bookmark/Email Button] Unwanted Line Break After Upgrade of Add To Any Plug

  • Resolved sammy123


    I upgraded to the and have this line break that I don’t want with:

    <?php if( function_exists(‘ADDTOANY_SHARE_SAVE_KIT’) ) { ADDTOANY_SHARE_SAVE_KIT(); } ?>

    I am using the text text only button. After this recent upgrade, there there is a line break before and after the button. I don’t want it. How do I get this fixed?

    Any help? Thanks!

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author micropat


    Nice catch, Sammy. That’s something we’ll probably want to get changed back in the next version.

    If you’d like to have this fixed on your site in the meantime, just include the following CSS code in your theme’s main stylesheet, or in the addtoany.min.css stylesheet:
    .addtoany_list { display: inline; }

    Thanks for the fix and a great plugin!

    I switched from ShareThis to AddToAny because there wasn’t a line break, and then the update added a line break… Thanks for the fix, too.

    Triple thanks.

    Plugin Author micropat


    If you’re using the AddToAny button only (no standalone service icons), another option would be to use ADDTOANY_SHARE_SAVE_BUTTON instead of ADDTOANY_SHARE_SAVE_KIT.

    <?php if( function_exists('ADDTOANY_SHARE_SAVE_BUTTON') ) { ADDTOANY_SHARE_SAVE_BUTTON(); } ?>

    Might be a little faster. 🙂 Again, the next release will have this fixed anyway.

    Thanks for the Info. I don’t want to mess around with css atm, if I have to change it back soon ™, I’ll just sit tight and wait for the update.

    Thanks for the reply



    Concerning Version .

    I tried de-selecting “Use CSS stylesheet” in the “Advanced Options” on the Settings page. It didn’t help. The only thing that works for me now is deleting addtoany.min.css in /wordpress/wp-content/plugins/add-to-any/.

    My problem is definitely greatly to do with my homemade theme. It started life as an old-fashioned, also homemade, table layout. I manually converted to div layout. I really struggled with it because I was learning css during the process.

    Sooner or later, I’ll have to start over from scratch because several plugins have broken my theme in the same way. Some are too extensive simply to opt out of using the plugin’s css.

    In case it will help anyone who’s searching for answers (workarounds…), this is also cross-posted at



    Sorry for the thread necromancy, but for me the display: inline fix only solves the problem 50%. The line break after addtoany is gone, but I still can’t get rid of the line break BEFORE addtoany. I’m using the text only version.
    Any clue what I’m doing wrong here? You can see the problem here:
    I just can’t find a reason for the unwanted line break.

    Apart from that for me AddToAny is the perfect share/bookmark plugin. Great work!

    Seriously, why does this keep changing with every version? I want the share link to be displayed inline. I don’t want a line break. How do I fix it now?

    Edit: I fixed it. Do this:

    if ( ! isset($args['html_container_open']))
    		$args['html_container_open'] = "<div class=\"a2a_kit addtoany_list\">";
    	if ( ! isset($args['html_container_close']))
    		$args['html_container_close'] = "</div>";

    Delete the DIV tags.

    Once again, the line break is back. Can the developer get rid of this or create an option for selecting it???

    Use the fix I posted above on add-to-any.php.

    Thanks, just deleted the div tags completely.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Plugin: AddToAny: Share/Bookmark/Email Button] Unwanted Line Break After Upgrade of Add To Any Plug’ is closed to new replies.