Share Buttons by AddToAny
[resolved] [Plugin: AddToAny: Share/Bookmark/Email Button] Facebook share does displays old data (5 posts)

  1. semyl
    Posted 4 years ago #

    When I share a post to Facebook, the following URL opens:


    The preview page shows an 'old' description and an 'old' image. If I remove the t attribute so that the URL is


    then I get the updated image and description.

    I've tried 'linting' my pages, but no change. I can only figure out that AddToAny is encoding something in the URL that serves old data.

    Why is this and how can I fix it?


  2. semyl
    Posted 4 years ago #

    To update, I actually discovered that it is the extra %20 after the u attribute and before the t attribute that is causing the old information to appear.


    works as expected.

    Any help will be appreciated, thanks.

  3. semyl
    Posted 4 years ago #

    FYI, I fixed it by linting http://truthquestions.org.uk/is-it-human-to-need-god/+

    For some reason the + is added by AddToAny, making the URL different so my previous lints weren't working.

    Maybe it would have been scraped sometime in the next 24 hours, but I didn't want to wait that long!

  4. micropat
    Plugin Author

    Posted 4 years ago #

    It's not AddToAny. Something is up with your setup. Check out your source for instances like:

    <link rel="alternate" type="application/rss+xml" title="Truth Questions ยป Will It Work This Year? Comments Feed" href="http://www.truthquestions.org.uk/will-it-work-this-year/ /feed" />

    <link rel='start' title='Is it Human to Need God?' href='http://www.truthquestions.org.uk/is-it-human-to-need-god/ ' />
    <link rel='prev' title='Looking For The Best Gift?' href='http://www.truthquestions.org.uk/looking-for-the-best-gift/ ' />

    etc. You've got a trailing space character in many places.

  5. semyl
    Posted 4 years ago #

    Interesting.. thanks for spotting that!

    Found the extra trailing space in my permalink settings.

    Incidentally though, as others may make the same mistake and to all appearances their site will work as normal, perhaps AddToAny could strip trailing spaces from the URL before passing it to Facebook?

    I had tried to lint the pages with a trailing space, but that didn't scrape it properly - I guess it was a Facebook thing that needed me to use the plus symbol in the linter. And I only considered that because I noticed one of my pages came up twice on the list of Top Pages, once with a plus and once without.

    Thanks for the help micropat!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Share Buttons by AddToAny
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic