Support » Plugin: AddToAny Share Buttons » [Plugin: AddToAny: Share/Bookmark/Email Button] Code displayed where it shouldn't be displayed

  • Issue #1:

    Using AddToAny to share any of my blog posts via Twitter produces the following kind of tweet:

    <span data-type="input" data-post_id="7860" class="fee-field fee-filter-the_title">From Crawford With Book</span> - http://j.mp/i6fRaO

    Obviously, no code should be displayed.

    Issue #2:

    Checking “Show the title of the post (or page) within the menu” produces this. Again, a chunk of code is displayed. (The same code as in Issue #1 above.)

    Issue #3:

    I’d like to display the the AddToAny icon at the bottom of my posts in FeedBurner BUT to insert it manually at the bottom of my blog posts on my site. The problem is that it is impossible to check “Display at the bottom of posts in the feed” without ALSO checking “Display at the bottom of posts,” in which case the icons at the bottom of my posts appear at their preset locations, which I cannot modify manually.

    Blog URL: http://blog.cyberquill.com

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author micropat

    (@micropat)

    Thanks for clearly outlining your issues.

    I tried to reproduce issues 1 & 2, but it seems to be working perfectly. There’s no code bleeding at all. If you’re still seeing those issues, which browser are you using? My first assumption would be that it’s a theme issue, but again, I can’t reproduce.

    Issue #3 is a really good point. I’ll put that in the internal bug tracker to be fixed.

    You’re right, the code bleed issue appears to be confined to Google Chrome. No problem with IE, FF, Safari, and Opera.

    Also, the WP AddToAny plugin still uses the “old” buttons with the old Twitter icon. (I’ve installed the new button using the Image URL option.)

    Plugin Author micropat

    (@micropat)

    Well hmm… I testing using Chrome 8.0.552.224 beta. 🙂

    Sounds like your Chrome setup has a local caching issue. Hard-reload one of your pages with AddToAny on it by pressing either Shift + R or Ctrl + R. If that doesn’t work, try clearing your local cache.

    I’m curious, which channel or version of Chrome are you running? Regular, Beta, or Dev channel?

    Indeed, clearing my cache solved it. Thank you. So I suppose the problem may show up anytime in Chrome browsers without a cleared cache.

    PS: Less than 24 hours after solving the issue by clearing the browser cache, the problem came back. I cleared the cache again, and the code bleed went away. There does not seem to be a permanent solution.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Plugin: AddToAny: Share/Bookmark/Email Button] Code displayed where it shouldn't be displayed’ is closed to new replies.