Support » Plugin: Share Buttons by AddThis » [Plugin: AddThis] Plugin not working with WP 3.4.1

Viewing 15 replies - 16 through 30 (of 39 total)
  • _mjk_

    (@_mjk_)

    @lucidnz Luke, it looks like it might just be a JS error (your body has an undefined load function). Try removing onload=”initialize” from your theme’s body tag:

    <body ... onload="initialize()">

    @ecksteing Hmm, yeah, it’s definitely not being output there. Can you send me a screen shot of your basic and advanced config? matt at addthis dot com. Thanks!

    _mjk_

    (@_mjk_)

    @russ_s I was able to set up a blog with this problem. Tell me if this mimics your setup:

    – example.com/ – home page, no sharing desired
    – example.com/blog – page template with a blog excerpt loop.

    If I just enabled excerpts but did not enable the “home page” checkbox, nothing showed up — because WordPress considers that /blog template to be the “front page” and right now we consider “home page” and “front page” synonymous although technically they’re not. If it’s really easy for you to test, I’d be curious to know if enabling the homepage and excerpt display resolved your problem, or if the buttons still didn’t display after excerpts even with homepage checked.

    russ_s

    (@russ_s)

    Hi Matt
    Our setup is not quite how you mention above.

    We have 1 lot of FTP space / webspace. Within this webspace is our website and blog, in the following configuration:
    ourdomain.com/ – main website run using Joomla
    ourdomain.com/blog/ – blog site run using WordPress

    The homepage to our blog, is a list of blog posts using excerpts. We do not have a static page as our homepage on the blog – we have our Joomla based website for that. Each part of our website has its own database.

    I have checked in my test environment and i have both the “hompage” and “excerpts” tickboxes enabled on the Advanced tab within the AddThis settings. If i disable the “homepage” option it makes no difference, the AddThis icons still don’t appear.

    _mjk_

    (@_mjk_)

    Interesting. Would you feel comfortable emailing me your theme as a zip? I’d love to be able to reproduce the problem our dev environment.

    russ_s

    (@russ_s)

    @_mjk_
    I am using the “Red Modern” theme, which is freely available via the WordPress built in theme search.

    However, i don’t believe it matters which theme you use. I have even tried the built in themes you get with WordPress as default. If you change the way it displays blog posts (i.e. change “<?php the_content(); ?>” to “<?php the_excerpt(); ?>” in the code), the AddThis buttons disapear.

    I have even followed a online tutorial to create my own very basic theme and when displaying excerpts no AddThis buttons show.

    _mjk_

    (@_mjk_)

    @russ_s I’ve updated our development version with a possible fix–the developer of the excerpt functionality is no longer actively contributing, but I think my change makes sense. I’m going to talk to him and regress it to make sure it doesn’t break something else, but if you’d like you’re more than welcome to try it out now! (http://downloads.wordpress.org/plugin/addthis.zip)

    _mjk_

    (@_mjk_)

    Actually @russ_s I noticed something else, which is that in the production plugin (2.4.3), excerpts are only set to display if you’ve enabled buttons at the BOTTOM of each post. Can you confirm that was or was not the case?

    lucidnz

    (@lucidnz)

    @matt Thanks that fixed it.

    Cheers

    L

    russ_s

    (@russ_s)

    @matt
    our buttons are set to show at the bottom of the post

    Hi Every one.
    How do I set to show the buttos at the bottom of the post? (in summary blog post option).

    @leo4all, you can set it from your admin settings. Navigate to Settings > Addthis. There you will have an option “Choose the sharing tool to display below the post”. Pick the right one you want and hit save.

    Incase you want to show it along excerpts in home page, switch to Advanced tab and select Excerpts.

    Let me know if it didn’t work.

    Hi @srijith.v
    – I have enable the first option at Settings > Addthis
    “Choose the sharing tool to display above the post”

    – Also the excerpts option is enable,
    – And in the template-blog.php file force excerpts to show

    <?php the_excerpt(); ?>

    Using WordPress 3.4.1.
    Addthis Version 2.4.3

    But still doesn’t appear.

    Hello. I got two pages:

    1 – http://www.aotopo.com.br/servicos/
    2 – http://www.aotopo.com.br/blog/

    In both pages I inserted The addThis plugin.
    Local testing is perfect for both, but online just the first one is working.

    P.S. In 2nd the addThis plugin is located at post-content ( just before the “Leia Mais” buttons.

    If somebody knows why, please help me.
    Thanks

    @erick: I couldn’t find addthis_widget.js being imported to the page. How did you add AddThis? Did you use the plugin available for WordPress?

    You will need to include http://s7.addthis.com/js/300/addthis_widget.js to the page to render the buttons.

    I am using a trick that I’ve found somewhere that adds arbitrarily addThis in any element of the page rather than include it just on the top or bottom of the posts. That requires unmark these “adding to page” default options of the plugin.

    I’ve imported the script you told me in my footer and Is working perfectly.

    Thank you very much

Viewing 15 replies - 16 through 30 (of 39 total)
  • The topic ‘[Plugin: AddThis] Plugin not working with WP 3.4.1’ is closed to new replies.