Support » Plugins and Hacks » [Plugin: Add to Any: Share/Bookmark/Email Button] Incompatibility Issue With AdSense IE Combination

  • First, I just want to say that I LOVE this plug-in.

    I just installed an Ad through Google AdSense on my SideBar.

    On Firefox: the Sidebar Ad displays perfectly on Homepage, Category pages, and individual posts.

    On IE 8: the Sidebar Ad displays perfectly on Homepage, Category pages, but doesn’t appear on individual posts.

    I asked about it on Google AdSense Help Forum, and this guy asked if I was using WordPress and ‘Add to Any’ plug-in. He said he had the same problem, and it went away when he deactivated ‘Add to Any’ plug-in.

    I deactivated ‘Add to Any’ and the add immediately displayed in Sidebar for individual posts on IE 8.

    I’m using WordPress 2.8.5. I hope that this can get resolved, because I love the plug-in.

    http://wordpress.org/extend/plugins/add-to-any/

Viewing 15 replies - 1 through 15 (of 19 total)
  • Hi, I have the same issue, and had to remove both the “Subscribe” and “Share” plug-ins. I also use WordPress 2.8.5.

    bwaltar,
    Just curious, did you by any chance find another comparable plug-in similar to ‘Add to Any’ that worked with the IE and AdSense combination?

    Hi CallUp,

    No, not yet. I just removed them for the time being, as my blog is brand new this week and I want to get the ads working sooner than later.

    I just contacted the “Add to Any” team on their website to see if it’s a known issue and will report back (if they don’t).

    @callup @bwaltar – thank you both for the speedy reports. This issue was caused by a recent change in the AdSense code that conflicted with AddToAny. Fortunately we were able to produce a workaround within 24 hours and that fix is now live (no plugin update required). Simply clear your cache or refresh a page with AddToAny on it to see the changes immediately.

    Cheers!

    Thanks – works great now!

    -Bruce

    micropat,
    That is so cool that you got that sorted out as quick as you did.

    Thank you so much!

    It’s back working perfectly. This is one of the best plug-ins out there.

    Best regards.

    Well, darn, this issue is back. I upgraded to WordPress 2.8.6 in case it’s relevant.

    I am having the exact same issue. Latest version of WordPress, using IE8. I hope they fix it soon. This plugin is just what I was looking for, and I love its professional appearance.

    I’m having the same problem.

    Same problem few weeks ago.
    Then I used sourcecode direct from addtoany website (without plugin for wordpress). Now I use plugin and all is ok.

    I tried your solution and it gives the same results, AdSense (images) isn’t showed in IE while it works alright from other browsers.

    I hope devs read this thread since it’s marked as resolved… Until then plug-in disabled.

    I am using adsense at the footer of my site and the latest version of wordpress and add to any. In Internet Explorer 8 the left bottom side of the page says there is an error on page with the add to any enabled..

    It reports this.

    Message: ‘a2a_as_last_parent’ is undefined
    Line: 1
    Char: 19180
    Code: 0
    URI: http://static.addtoany.com/menu/page.js

    I hope there is a fix for this.

    Thanks…..M

    @mal22 that issue was fixed.

    Others: If you hard-reload a page with the button on it (or clear your browser cache), is this still a problem? If so, how exactly do you have AdSense implemented? Thanks!

    I cleared the cache, same effect, ad shows until your button is loaded and then it disappears. I use original Google code for that ad since it is on fixed place (no plug-in used to display it).

    <div id="sidebar-ads">
    <script type="text/javascript"><!--
    google_ad_client = "pub-my_pub_number";
    /* All pages middle right */
    google_ad_slot = "some_number";
    google_ad_width = 300;
    google_ad_height = 250;
    //-->
    </script>
    <script type="text/javascript"
    src="http://pagead2.googlesyndication.com/pagead/show_ads.js">
    </script>
    </div>

    Yeah, issue still happens. Seems that text ads now show fine (odd), but not image ads. I use similar original Google code in the WordPress text/HTML widget in various sidebars and headers/footers.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘[Plugin: Add to Any: Share/Bookmark/Email Button] Incompatibility Issue With AdSense IE Combination’ is closed to new replies.