Support » Plugins and Hacks » [Plugin: Add to Any: Share/Bookmark/Email Button] Drop-down not working, code seems correct

  • tomdolle

    (@tomdolle)


    I’m working in WooTheme The Journal, newest version. I’ve been trying to get either Add to Any or Share This plug-ins to work. Add to Any shows up, but links to another page instead of opening a drop-down menu as it should. ShareThis won’t even appear.

    WP plug-in FAQ says the following:

    Why isn’t the drop-down menu appearing?
    It’s likely because your theme wasn’t coded properly. Using the Theme Editor, make sure that the following piece of code is included in your theme’s footer.php file just before the </body> line:

    <?php wp_footer(); ?>

    Mine is coded that way, but doesn’t work. Is it a Woo issue?

    Site: http://www.thehillbrooklyn.org/wptestsite

Viewing 15 replies - 1 through 15 (of 24 total)
  • micropat

    (@micropat)


    Hi Tom,

    You’re right, AddToAny appears to be setup correctly in your site’s source code. It’s possible that either a plugin or your theme’s own CSS stylesheet is overriding the position of the drop-down menu.

    First try switching your theme to the default WordPress theme.

    If the drop-down still doesn’t appear, switch back to your current theme and try disabling all other plugins.

    tomdolle

    (@tomdolle)


    Thanks for getting back. I tried the default theme, and turned off all plug-ins except Addtoany. Unfortunately, still didn’t work as drop-down menu.

    Im having the same problem at http://www.mechapinoy.net
    Drop-down menu is not working.

    @tomdolle looks like you have AddToAny working perfectly on-click!

    @hentai Looks like you need to fix your theme’s footer file. Please see the FAQ for “Why isn’t the drop-down menu appearing?” http://wordpress.org/extend/plugins/add-to-any/faq/

    Hello,

    it doesn’t work for me at Tomdolle’s site. And I have the same problem on my site – but only using Firefox. Using IE everything seems to work correctly. Here’s the link http://www.mydani.com

    Seems like it’s an issue with Firefox and the plugin – on the addtoany homepage it’s working correctly.

    Regards!

    @mydani interesting. The drop-down works on your site and Tomdolle’s here on Firefox 3.6. What version of Firefox are you using?

    Hello,

    it is version 3.5.5!
    And I’ve already disabled all Addons but there’s still no popup visible.
    Let’s see whether 3.6 helps.:)

    Ok, 3.6 does not help – and I’ve also tried starting with a fresh firefox profile, still no change…
    Damnit!

    It might be possible that Firefox is storing a cached version of the AddToAny script, and perhaps that version had a bug.

    Try hard-reloading (hold Shift + click Reload) your blog’s homepage. That should get you on the latest AddToAny version.

    The drop-down should appear on hover.

    If you still have problems, are you noticing any JavaScript errors? Tried changing your theme back to the default?

    Haha. When I hover the addtoany link the following error is registered in the error console:

    Error: a2a.gEl(“a2a” + a2a.type + “_title”) is null
    Source: http://static.addtoany.com/menu/page.js
    Row: 1

    Hello again,

    while testing I found that in single post mode this works, but as soon as there are more than one button with link to addtoany, the mouseover does not work anymore.

    There is no difference in the code (!) between single post and multiple posts… I can’t think of any solution until now…

    Regards

    Did you try hard-reloading your homepage with Shift + clicking the Reload button in Firefox (Cmd + F5 on Mac)?

    I can’t reproduce your problem in any browser, and that error leads me to believe it’s a browser cache issue.

    Hello,
    I have the same problem. You can check on http://blog.friup.ch
    I have Firefox 3.6, WordPress 2.9.1 and AddToAny .9.9.4.7, on the homepage the popup wont show up with Firefox but with IE its ok.
    I tried to empty the browser cache, the default theme but I cant find the problem. Apparently I have the same problem than mydani with the javascript error.

    Thanks for your help.

    Hello Micropat,

    I’ve already tried this with a new firefox profile, and on another PC, but still no improvement. Are you able to see the mousehover even on the very first site which has several posts?
    Did you also refresh your cache? 😉

    Regards,
    Daniel

    Hello Daniel & radgo,

    Thank you for all your help.

    Some good news: I was finally able to reproduce! It appears that a bug made its way into AddToAny that affects some instances where users have a browser locale other than “en-US” set. Terrible, I know!

    More good news: We’ve already identified the problem. Since we’ve been doing a lot of optimization behind the scenes, we “over-optimized” the language portion in last week’s release. 😉

    We’re working on a fix right now, and will push out an automatic release ASAP – no plugin upgrade required. I’ll post here when it’s released.

    Just curious, what are your languages set as in Firefox? 🙂

    Cheers,
    Pat

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘[Plugin: Add to Any: Share/Bookmark/Email Button] Drop-down not working, code seems correct’ is closed to new replies.