WordPress.org

Support

Support » How-To and Troubleshooting » Plugin "Add New" Button Missing!! Help!

Plugin "Add New" Button Missing!! Help!

  • Hey All!

    Im New to this, but here goes. I had my website recently developed by a great company in the UK. Anyways, i am now personalizing it with pictures and things, and wanted to add a plugin that could handle pictures and albums nicely. Unfortunately, when i went to my plug in tab and tried to find the add new button, it was Missing! What to Do! I dont know how HTML code works, so if someone could direct me in laymans terms that would be INCREDIBLE!

    Thanks

    Stephen

Viewing 15 replies - 1 through 15 (of 15 total)
  • Your developer has perhaps removed this, you should contact them.

    You could try going to the URL manually. Just add /wp-admin/plugin-install.php to the end of your URL. If this works, then it’s just been hidden from your admin menu. This could be hidden in your functions.php file of your theme or by a plugin such as Adminimize.

    Hey Rab!

    Thanls for that! I tried it but it says “You do not have sufficient permissions to access this page”. Whats the deal with that!? Im logged in through my Admin panel. My host provider is Godaddy and i have full access to my FTP ect. Is there any way I can fix this? is there anyone that can share some steps?

    Your user account you use to login to WordPress might not have full administrator access. It’s difficult to determine exactly what the issue is here. Are you unable to contact your developer?

    There is ways which you could sort this out – but it could be a lot easier asking the person who set this up for you as what you’re seeing could have been done a few different ways.

    Problem is my Administrator is in the UK and its been a week since i Contacted them about helping me with this. No answer! They were a great company to work with when they were building it, and i even told them that I would PAY to have them help me, so they wouldnt be wasting there time but still no response. SO thats what i am faced with. Now i guess im on my own to figure it out. Thats what turned me to the wordpress forums! And I so appreciate your help already.

    Is there a trial and error process that you could walk me through?

    here is a list of my plugins that have been added by the developer:

    Capability Manager (Manage User Capabilities and roles) by Jordi Canals
    Contact form 7
    Events Manager
    Fancybox for WordPress
    Microsoft Ajax Translation
    Simple wordpress backup

    These are the only plugins I have. I have deactivated the “Capability Manager” just to see what it did and still no difference.

    They could be on a Christmas holiday, a lot of places here close around this time so don’t give up just yet! 🙂

    Sometimes developers “lock” things down to ensure the site structure stays the way they create it. Rightly or wrongly, it’s done.

    If you really don’t want to hold out till after the holidays and want to try and gain access then you could try reading through “How to Add an Admin User to the WordPress Database via MySQL”. That’s me assuming that the problem is that you don’t have a full Admin User account. Further than that, I’m afraid I don’t have the time to run through everything with you – but perhaps someone else here can.

    You should know what you’re doing with some of this stuff, doing something wrong could have bad consequences on your site, especially if you’re playing around with the database. You should consider taking a backup prior to any changes.

    Good luck!

    hey I aure so appreciate your help! I dont know alot really, just learning whats what so far so maybe i should take the wait approach on fixing it myself without someones help.

    Thanks so much though I greatly appreciate your help! Merry Christmas!

    ^ WPMS (multisite) setups you would not see the add new there. If you are using multisite.

    How would I know if i am using a Multisite? is there a way to check?

    If you have the option in the top that allows you to go to your different sites that you have installed ;/ erm .. if you have a system administrator panel to go to

    nope i dont have that. Its just the one site with 22 pages lol. So that rules that one out i guess

    .. if you open your wp-config.php file in your root installation folder and it has info inside of it for the multisite install

    ^ btw re-activate that user capability plugin and adjust the administrator to be able to do plugins, that would/should reinstate it

    The Capability manager when reactivated doesnt give me a settings button haha it only has deactivate or reactivate. AARRGGHH!

    This one should be the one being used:
    http://wordpress.org/extend/plugins/capability-manager-enhanced/

    If you have this one installed, it wouldn’t be usable:
    http://wordpress.org/extend/plugins/capsman/

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Plugin "Add New" Button Missing!! Help!’ is closed to new replies.