Support » Plugin: Add Link to Facebook » [Plugin: Add Link to Facebook] Since updating, plugin only accessible from one account and won'

  • Version 1.7 and 1.8 of this plugin worked fine, then upgrading to version 1.9 broke the plugin. All settings were wiped out. Every attempt to authorize the plugin started leading to the following error:

    – Invalid redirect_uri: Given URL is not allowed by the Application configuration.

    After several dozen attempts to get it to work without success, I decided to reupload version 1.7, which I still had on my system from my latest site backup. I got the app to authorize again. So, that part is working fine. But, the upgrade caused another problem I still can’t resolve.

    This plugin no longer appears in the sidebar of the master admin account under which I upgraded it. When I try to access it from the direct link in my browser history on master Admin account, it still says:

    – You do not have sufficient permissions to access this page.

    Other than rolling back my database to right before the update (not a desirable option, since I added new content over the weekend) I’m not sure what to do here. I have ‘share with all users on this site’ selected and edit-posts permission set, so the master Admin account shouldn’t be getting permissions errors. It appears something isn’t being written to the database correctly. Any idea where to look (what setting in which table)?

Viewing 1 replies (of 1 total)
  • First of all: version 1.9 is not very different from the previous two versions. If all settings were wiped out, it could be you have checked the option ‘Clean on deactivate‘ (however, this wipes only the settings of the current user, not the global options like the Facebook application ID and secret).

    About the authorization error: did you try the solution in the FAQ? It is very unlikely version 1.7 solved this problem.

    About the permission problem: only the admin that checked the option ‘Share with all users on this site‘ can access the settings. If this is not the case, contact me using this contact form and I will try to help you.

Viewing 1 replies (of 1 total)
  • The topic ‘[Plugin: Add Link to Facebook] Since updating, plugin only accessible from one account and won'’ is closed to new replies.