WordPress.org

Forums

Add Link to Facebook
Not posting images (16 posts)

  1. rusty_nail
    Member
    Posted 4 years ago #

    I have been using the plugin successfully for a bit, but i just upgraded to 1.9 and now images aren't being posted under certain circumstances. If i have a featured image, or a simple image in the post, it wont see them in the meta box or post an image, but if i do a gallery, it will work, but the choice in the meta box wont override "let facebook choose"

  2. M66B
    Member
    Posted 4 years ago #

    Can you please tell what your option 'Link picture' is set to?
    Can you post the custom value 'al2fb_facebook_link_picture', for the post(s) you think where not processed correctly?

  3. bestsaigon
    Member
    Posted 4 years ago #

    I turned on option using Open Graph and has same issue.

    I found that function WP_head() alway gets $link_picture from 'c_al2fb_meta_link_picture' but the old post has not al2fb_facebook_link_picture (but has 'c_al2fb_meta_image_id'). So it always gets empty string and uses the default.

    I made a hot fix like that:

    Before:
    // Get link picture
    $link_picture = get_post_meta($post->ID, c_al2fb_meta_link_picture, true);
    if (empty($link_picture)) {
    $picture = get_user_meta($user_ID, c_al2fb_meta_picture_default, true);
    if (empty($picture))
    $picture = self::Redirect_uri() . '?al2fb_image=1';
    }

    After:
    // Get link picture
    $link_picture = get_post_meta($post->ID, c_al2fb_meta_link_picture, true);
    if (empty($link_picture)) {
    $image_id = get_post_meta($post->ID, c_al2fb_meta_image_id, true);
    if (!empty($image_id) && function_exists('wp_get_attachment_thumb_url')) {
    $picture = wp_get_attachment_thumb_url($image_id);
    }
    if (empty($picture)) {
    $picture = get_user_meta($user_ID, c_al2fb_meta_picture_default, true);
    }
    if (empty($picture))
    $picture = self::Redirect_uri() . '?al2fb_image=1';
    }

    And this solution works with me!

  4. M66B
    Member
    Posted 4 years ago #

    Thanks for this fix! It will be included in the next released (within an hour).

  5. bestsaigon
    Member
    Posted 4 years ago #

    Thanks for your quick response and do credit me in ChangeLog.

    But I think above solution is only a work-around solution for old posts.

    In function 'Save_post($post_id)', you should add more source code to update 'al2fb_facebook_link_picture' same way as you wrote in function 'Add_link($post)'.

    Because with new post, you launch function 'Add_link($post)' one time, and 'al2fb_facebook_link_picture' field has a value.

    With above solution, it's alway get the data from 'al2fb_facebook_link_picture' and it doesn't care that 'c_al2fb_meta_image_id' was changed or not.

    It means with new post, it always use the first chose image when Add_link was launch.

  6. M66B
    Member
    Posted 4 years ago #

    Actually I think it is good that the plugin always serves the same, original selected image. Else the image could change when the plugin settings are being changed and I don't think that is a good idea. There are already enough questions about which image is being selected.

    If you really want to change the image of an post, you could just change the 'al2fb_facebook_link_picture' value.

    I wouldn't be difficult to select the image for the Open Graph Protocol in the same way as adding a link does, but again I prefer a consistent behavior where the image of the Open Graph Protocol is always the same as the one when the link is added.

  7. M66B
    Member
    Posted 4 years ago #

    @bestsaigon: version 1.16 has an hybrid solution: if there was a link added for a post/page the picture that was used for the link is selected for the Open Graph Protocol, else the picture that would be used when adding the link is selected. So, there will be always a valid picture in the meta tags (as far as possible given the selected options, else the WordPress logo will be used as default), and the behavior is consistent when there was a link added. So, I hope we have "everbody happy" now :-)

  8. David Radovanovic
    Member
    Posted 3 years ago #

    I've have a similar issue. I just want my Link Picture settings to propagate.

    I've set my Custom picture URL and Default picture URL: http://www.on-your-mind.com/wp-content/uploads/2011/10/on-your-mind-header21-e1320699857597-141x150.jpg

    though the page code keeps displaying:

    <meta property="og:image" content="http://www.on-your-mind.com/?al2fb_image=1" />

    which is the WordPress logo.

    Any advice would be appreciated. BTW - I have Version 1.116 release.

    Thanks!

  9. M66B
    Member
    Posted 3 years ago #

    The WordPress logo is the default image for the home page. Download and install the development version (follow the link in the changelog) to have the custom/default image configured. Note this only works for single user blogs (blogs where only one user has authorized Facebook).

    Your single posts do have a link picture, for example this one.

  10. David Radovanovic
    Member
    Posted 3 years ago #

  11. David Radovanovic
    Member
    Posted 3 years ago #

    However, even after 7 hours facebook still wants to use the WordPress logo. Anyway to force facebook to see the new "Like" image? Thanks!

  12. M66B
    Member
    Posted 3 years ago #

    It is said that the Facebook URL Linter, now called Facebook debugger, refreshes the cache, but I cannot confirm this.

  13. M66B
    Member
    Posted 3 years ago #

    And about Facebook caching: think in days, not hours.

  14. David Radovanovic
    Member
    Posted 3 years ago #

    Thank you!

  15. gujjubond
    Member
    Posted 3 years ago #

    How do I use this plugin for Old Posts ?

  16. M66B
    Member
    Posted 3 years ago #

    See the FAQ, question U09.

    To keep an overview, it is customary to ask questions about a different subject in a new thread. So, if you have more questions, please create a new one.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Add Link to Facebook
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic