Support » Plugin: Active Directory Integration » [Plugin: Active Directory Integration] Logon Test confuses password and username

  • Hello There:

    I couldn’t find an answer to this problem on the net so I thought I would ask this forum.

    after setting up AD Integration plugin, it appears that the username that is passed to openLDAP is blank and the password that is passed is in the username. AD bind username and password appear to be correctly passed.

    Any help would be greatly appreciated.

    Thanks

    jg

    here is the output of the test:

    [INFO] method authenticate() called
    [INFO] WP version: abc
    [NOTICE] username:
    [DEBUG] password: jong

    [INFO] loading options…
    [INFO] Options for adLDAP connection:
    – account_suffix:
    – base_dn: OU=SSCG,DC=sscg,DC=local
    – domain_controllers: dc08.sscg.local
    – ad_username: CN=XXXXX,OU=System Accounts,DC=sscg,DC=local
    – ad_password: XXXXX
    – ad_port: 389
    – use_tls:
    [NOTICE] adLDAP object created.
    [INFO] max_login_attempts: 3
    [INFO] users failed logins:
    [ERROR] Authentication failed
    [WARN] storing failed login for user “”

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author glatze

    (@glatze)

    Sounds wierd. Have you fixed this problem. If not send me an email christoph.steindorff_at_ecw.de.

    I too am having this problem. However i tried logging in with an account in the Users folder in AD but any of the other accounts in my domain don’t work. Any help is greatly appreciated. Thank you.

    Plugin Author glatze

    (@glatze)

    Hi Stace,
    would you send me the output of the Test Tool. Then I can dig a little bit deeper (cst_at_ecw.de) and help you. Don’t forget to delete or better alter security relevant informations.

    And you should try the development version: http://downloads.wordpress.org/plugin/active-directory-integration.zip

    Hi,
    I’m trying the plugin version 0.9.9.9 on WordPress 3.0.1.
    With any user, I receive the same error:

    AD Integration Logon Test
    openLDAP installed
    [INFO] method authenticate() called
    [INFO] WP version: 3.0.1
    [NOTICE] username: xxxx
    [DEBUG] password: yyyy
    [INFO] loading options...
    [INFO] Options for adLDAP connection:
    - account_suffix: domain.local
    - base_dn: cn=Users,dc=domain,dc=local
    - domain_controllers: my.domain.local
    - ad_username: Administrator@domain.local
    - ad_password: xxxx
    - ad_port: 389
    - use_tls:
    [NOTICE] adLDAP object created.
    [INFO] max_login_attempts: 3
    [INFO] users failed logins: 0
    [ERROR] Authentication failed
    [WARN] storing failed login for user "xxxx"
    Logon failed

    Is this an unsolved bug?
    Thanks

    Plugin Author glatze

    (@glatze)

    Your Base DN is wrong. Use “OU=Users,dc=domain,dc=local” or “dc=domain,dc=local”.

    Thanks very much.
    With “dc=domain,dc=local” I can login with domain accounts but only on primary site, the one specified in the “wp_site” DB table and in wp-config.php (define(‘DOMAIN_CURRENT_SITE’, ‘myblog.mydomain.com’ );)

    I can’t connect with domain users into http://sub.myblog.mydomain.com/wp-login

    Is this normal?

    Plugin Author glatze

    (@glatze)

    Hi Gianfranco,
    I’m sorry to say, that the multisite support is still in development and a better support planned for version 1.1 which should come in April this year. I’ll do my best to get it out as soon as possible. Please let me know if you have any suggestions for 1.1.

    Bye
    Christoph

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: Active Directory Integration] Logon Test confuses password and username’ is closed to new replies.