Support » Plugins » [Plugin: Active Directory Integration] Doesn't grab user's real name from AD

  • When using the Active Directory Integration plugin for users to login in to my intranet site the plugin does not grab the users real name from AD. Their display name shows as If their name is a bit longer it is too long for the box that displays it and it runs over into a different part of the page. I have the plugin set to use the Common Name as the display name, but it did not work. I also tried using description, but that did not work either.
    Also because I have subdomains, I left the account suffix field blank. This allows subomain users to login using their full email address, (instead of just their username john.smith), but when the plugin populates the email field it shows as “”.

    I am running WordPress 3.0.1 and Active Directory Integration on a Turnkey Linux Application running on my own server.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Have you tried the development version (1.0 RC-1)?

    No, I haven’t. Where could I find that?

    You always find the last development version here:

    Do you know that this fixes the issue? I’m just a little hesitant to try this lest it make the whole thing stop working altogether.

    I have a similar issue but in my case when I run the test tool and examine the user account created there is no Name or last name. Could it be that this information is not being supplied by the AD? How would I know? Does this have anything to do with it being an “anonymous” request (no bind user/password setting?

    I tried RC1 since I saw there was allot of code around that added or changed. But how would I make sure that the Active Directy request contains the first and last name to begin with?

    I had the same issue with the email domain being appended even if there WAS an email passed. Apparently it was not making sure that the mail variable was blank as specified. I emptied that field and that specific issue went away. I just tested it after upgrading to RC1 and they did fix that. Well anyway I populated the field with the domain and it did not append to the users email address. I don’t know that it works as specified if that variable is not passed (blank) by the AD as I don’t have a test account with a blank email.
    So the RC1 appears to have fixed that specific issue.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Plugin: Active Directory Integration] Doesn't grab user's real name from AD’ is closed to new replies.