WordPress.org

Support

Support » Plugins and Hacks » Active Directory Integration » [Resolved] [Plugin: Active Directory Integration] Authentication failed … but.. WHY?

[Resolved] [Plugin: Active Directory Integration] Authentication failed … but.. WHY?

  • Set up the AD integration module, everything should be fine. Tested with multiple users; however just always fails authentication.

    from cli, can auth to user no problem with same credentials. redmine configured with same base dn, settings and it works fine. help! Where are the detailed logs?

    [INFO] method authenticate() called
    [INFO] ------------------------------------------
    PHP version: 5.3.2
    WP version: 3.2.1
    ADI version: 1.1.1
    OS Info : Linux web01.xxx.com 2.6.32-71.29.1.el6.centos.plus.i686 #1 SMP Sun Jun 26 15:21:38 BST 2011 i686
    Web Server : apache2handler
    adLDAP ver.: 3.3.2 Extended (201104081456)
    ------------------------------------------
    [NOTICE] username: testuser
    [NOTICE] password: **not shown**
    [INFO] Options for adLDAP connection:
    - account_suffix: xxx.com
    - base_dn: cn=Users,dc=xxx,dc=com
    - domain_controllers: dc.xxx.com
    - ad_port: 389
    - use_tls: 0
    - network timeout: 5
    [NOTICE] adLDAP object created.
    [INFO] max_login_attempts: 3
    [INFO] users failed logins: 0
    [NOTICE] trying account suffix "xxx.com"
    [ERROR] Authentication failed
    [WARN] storing failed login for user "testuser"

    http://wordpress.org/extend/plugins/active-directory-integration/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Same result for us. We’re running WP 3.2.1 on Win2003, Apache 2.2.16 and PHP 5.2.13. Have tried running WP in debug mode but it did not throw any info to the screen. Using an LDAP tool we are able to authenticate using the Base DN and user credentials that we configured in the plug-in. Any suggestions would be greatly appreciated. Thanks.

    greg.fenton

    @gregfenton-1

    Are you sure of your base_dn setting? Might that be ou=Users,dc=XXX,dc=com (i.e. not cn=Users)?

    greg.fenton

    @gregfenton-1

    BTW: have you tried just using base_dn: dc=XXX,dc=com ?

    We tried our Base DN. Not sure if it matters but ours is “dc=xxx,dc=xxx,dc=xxx” which basically has an extra domain component.

    Also tried the absolute path to the actual OU where my account is stored.

    Used an LDAP tool from the server where WP is installed and I was able to connect using both of the provided AD paths along with my account credentials.

    Set DEBUG mode to TRUE but it didn’t spit-out any info to the screen. Anyway of invoking msg’s?

    Also, does the plug-in work with sub domain names? i.e. sub.website.com?

    Thanks, AQ

    Plugin Author glatze

    @glatze

    Your account suffix is wrong. You should try “@xxx.com” not “xxx.com” as stated on the options page.

    Plugin Author glatze

    @glatze

    And yes: it works with subdomains like sub.website.com

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘[Resolved] [Plugin: Active Directory Integration] Authentication failed … but.. WHY?’ is closed to new replies.
Skip to toolbar