WordPress.org

Ready to get started?Download WordPress

Forums

Active Directory Integration
[resolved] Admin User ID 1 Login Fails Now (2 posts)

  1. Max625
    Member
    Posted 2 years ago #

    First of all thanks for this great plugin. Things were working properly for me - I had authenticated several users from my LDAP server and still was able to maintain the original User ID 1 login (appears this password was being stored locally in wordpress db, since there was no corresponding user on the LDAP).

    But...then I believe I made a small change to the User ID 1, something like changing the first name I believe (via the wordpress admin dashboard). From this point on I was not able login as User ID 1. I am sure I am using the correct username and password. As a feeble attempt to resolve this I created the user on the LDAP server. But from what I see in the code it isn't looking at LDAP for User ID 1, so this has no effect (which is good, I like that feature).

    I did not modify my settings either. Here is what I have configured:
    User Tab
    Account Suffix: blank
    Append account suffix: not checked
    Automatic User Creation: checked
    Automatic User Update: checked
    Auto Update User Description: checked
    Default email domain: blank
    Email Address conflict handling: Prevent
    Prevent Email Change: checked
    Display name: cn
    Show User Status: checked
    Password handling section
    all options are not checked

    Authorization tab
    All options are not checked

    Security tab
    Fallback to local password: not checked
    Max login attempts allowed: 3
    blocking time: 30
    user notification: not checked
    admin notification: checked

    User meta:
    I think I used all default settings here

    http://wordpress.org/extend/plugins/active-directory-integration/

  2. Max625
    Member
    Posted 2 years ago #

    I figured this out - but have kept the post in case a poor lost soul can benefit from it.

    Problem:
    my own incompetence

    Solution:
    1) enable Settings>User>Password Handling>Enable local password changes
    2) change the password for User ID 1 (luckily I had another admin account that could do this)
    3) disable local password changes setting

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.