Support » Plugin: Active Directory Employee Listing » [Plugin: Active Directory Employee Listing] Question with search

  • I’m using the latest version 0.2.1a and wordpress 3.4.2

    I’ve tried adding a widget as can be seen from the screenshot http://i.imgur.com/kZEuf.png but when I press search, it says no employees could be found. Ideally I would like the widget to work as it is exactly what I want to put on our front page.

    I also tried to put [ad-employee-list] into a page. This works brilliantly apart from one issue. Before I type in any names, it lists a huge number records as can be seen from this screenshot http://i.imgur.com/wk3ze.png If I type in a name that I want to search, it brings up the right result.

    edit: I’m also using AD authentication Integration as I read there might be some conflicts.

    Also trying out 0.30 now.

    http://wordpress.org/extend/plugins/active-directory-employee-list/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Not much luck with the 0.30 either.

    I tried using posting [ad-employee-list] into a page. When I first open the page. It loads up the first 10 search (which I set)it can find through ldap. It also have the following errors

    Warning: implode() [function.implode]: Invalid arguments passed in /opt/lampp/htdocs/wp-content/plugins/active-directory-employee-list/classes/class-active-directory-employee-list-output.php on line 407

    Search doesn’t work with 0.30 but it works fine for me in 0.2.1a.

    I also have a problem adding Active directory groups to retrieve. I added a group called “Domain Users” which all of our users are in. This breaks it completely and doesn’t even load any results. I have a feeling it’s because my base DN doesn’t include the AD group ones. But even then by looking at the accounts, it should be able to see which groups they are in.

    Active Directory Employee Widget and both AD Employee Widget gives the same error. It shows the first 10 results before you type anything into the search box and it gives the same error on line 407.

    Am I doing missing something?

    edit: I tried searching for ‘a’ and I got the following errors.

    Warning: Invalid argument supplied for foreach() in /opt/lampp/htdocs/wp-content/plugins/active-directory-employee-list/classes/class-active-directory-employee-list-output.php on line 904

    edit2: I’m running multisite but I’ve only applied this plugin to a single site. I’ve also disabled Active Directory Authentication Integration plugin from the whole network.

    Plugin Author Curtiss Grymala

    (@cgrymala)

    Thanks for the information. I’ll try to take a look at this over the next week or so and see if I can figure out what’s going on. The errors you included should help me narrow down the problem, hopefully.

    Great! I was worried that you have abandoned this plugin. I can’t find any other plugin that does the same thing. Let me know if you need any logs for troubleshooting. Thanks.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: Active Directory Employee Listing] Question with search’ is closed to new replies.