WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Active Directory Authentication Integration] 0.6 access test feature

[Plugin: Active Directory Authentication Integration] 0.6 access test feature

  • I am trying to configure AD using the [Plugin: Active Directory Authentication Integration] but can’t find the test feature mentioned in the forums.

    I have 1 user, its the super admin for both the only site and the only network on wordpress 3.2.1 install but whether I have the plugin network activated or just in the site I can’t find the option to test my settings to see where I am going wrong.

    A previous forum post mentioned test.php inside the plugin folder itself but that file didn’t come with the download I got.

Viewing 3 replies - 1 through 3 (of 3 total)
  • I tried a fresh install of wordpress and the plugin but when I enable the plugin I get the following wordpress debug errors.

    Disabling the plugin stops the errors but I was getting similar errors before I reinstalled wordpress and the plugin.

    I have define(‘FORCE_SSL_ADMIN’, true); in my wpconfig if that makes a difference

    Notice: Undefined index: page in /wp-content/plugins/active-directory-authentication-integration/class-active-directory-authentication-integration.php on line 357

    Notice: Undefined property: ADAuthInt_Plugin::$append_ad_suffix in /wp-content/plugins/active-directory-authentication-integration/inc/active-directory-authentication-integration.default-options.php on line 180

    Notice: Undefined index: opt_name in /wp-content/plugins/active-directory-authentication-integration/class-active-directory-authentication-integration.php on line 589

    I seem to have gotten it working. I didn’t have ldap:// before the AD domain controllers values. After I changed that and disabled debug the user is able to login (if they are new an account gets created in Users)

    Didn’t manage to find the testing feature in the plugin but prefixing my AD values with ldap:// worked

    Sorry for taking so long to respond. Things are really hectic on my end, so I haven’t had much time for support at the moment.

    There is no test feature in 0.6; but there is one available in the development version. In order to use it, you have to be logged into WordPress, then visit /wp-content/plugins/active-directory-authentication-integration/test.php to use it.

    With debug turned on, sometimes you won’t be able to login because of the fact that the debug outputs information to the screen before WordPress finishes setting up the cookies and redirecting.

    It’s strange that you had to include the ldap:// protocol at the beginning of the address. That shouldn’t be the case; but I’m glad you were able to get things working.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Plugin: Active Directory Authentication Integration] 0.6 access test feature’ is closed to new replies.