Support » Plugin: Article List Manager (arlima) » Plugin activation fails – despite correct PHP version.

  • Resolved Devotion



    Our server got PHP 5.3. Yet I can’t activate the Arlima plugin. This is what I get:

    Warning: require_once(__DIR__/classes/Plugin.php) [function.require-once]: failed to open stream: No such file or directory in /home/lxmbrg/public_html/mag/wp-content/plugins/arlima/arlima.php on line 15

    Fatal error: require_once() [function.require]: Failed opening required ‘__DIR__/classes/Plugin.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/lxmbrg/public_html/mag/wp-content/plugins/arlima/arlima.php on line 15

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author victor_jonsson


    The error message that your getting is in fact a proof that your servers has a PHP version lower than 5.3. The constant __DIR__ did not exist until version 5.3.0 and since PHP converts undefined constants to string the path will become “__DIR__/classes/Plugin.php” on servers having PHP version < 5.3

    But we’re currently working on version 2.5 of the plugin which will be compatible with version 5.2. It will probably be released during december of this year.

    / vic



    Hm, weird, according to our web host we do infact have PHP 5.3. :S

    I’ll contact them again.

    Can’t wait to get this plugin going!

    Plugin Author victor_jonsson


    Arlima does now (since release 2.5) support PHP version 5.2

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Plugin activation fails – despite correct PHP version.’ is closed to new replies.