Article List Manager (arlima)
[resolved] Plugin activation fails - despite correct PHP version. (4 posts)

  1. Devotion
    Posted 3 years ago #


    Our server got PHP 5.3. Yet I can't activate the Arlima plugin. This is what I get:

    Warning: require_once(__DIR__/classes/Plugin.php) [function.require-once]: failed to open stream: No such file or directory in /home/lxmbrg/public_html/mag/wp-content/plugins/arlima/arlima.php on line 15

    Fatal error: require_once() [function.require]: Failed opening required '__DIR__/classes/Plugin.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/lxmbrg/public_html/mag/wp-content/plugins/arlima/arlima.php on line 15


  2. victor_jonsson
    Plugin Author

    Posted 3 years ago #

    The error message that your getting is in fact a proof that your servers has a PHP version lower than 5.3. The constant __DIR__ did not exist until version 5.3.0 and since PHP converts undefined constants to string the path will become "__DIR__/classes/Plugin.php" on servers having PHP version < 5.3

    But we're currently working on version 2.5 of the plugin which will be compatible with version 5.2. It will probably be released during december of this year.

    / vic

  3. Devotion
    Posted 3 years ago #

    Hm, weird, according to our web host we do infact have PHP 5.3. :S

    I'll contact them again.

    Can't wait to get this plugin going!

  4. victor_jonsson
    Plugin Author

    Posted 3 years ago #

    Arlima does now (since release 2.5) support PHP version 5.2

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic