Support » Plugin: HubSpot Tracking Code for WordPress » Plugin Activation Error(s), Class Constructor, and Missing Activation Button

  • Hello,

    When activating/using the plugin on 4.6.1 (I don’t know if it’s exclusive to 4.6) and PHP7, There’s a couple warnings/errors:

    • Constructor Warning
      Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; HubSpotTrackingCodeAnalytics has a deprecated constructor in /.../plugins/hubspot-tracking-code/inc/class-hubspot-tracking-code-analytics.php on line 2
    • Activation Error (plugin still technically activates, though)
      The plugin generated 349 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin.
    • Settings: On HubSpot ID Save (WP_DEBUG on)
      Warning: Cannot modify header information - headers already sent by (output started at /.../wp-content/plugins/hubspot-tracking-code/inc/class-hubspot-tracking-code-analytics.php:2) in /.../wp-includes/pluggable.php on line 1174. The ID still saves, but there is no authentication button shown.
    • Settings: On HubSpot ID Save (WP_DEBUG off)
      ID saves, but no authentication button shown.

    Thank you very much for the plugin – I’ve used it on multiple sites and it works great! Let me know if there are any additional details I can provide. The issues with Debug on/off come from two separate sites (I noticed the problem on one 4.6.1 site without debug on, then tried the plugin on another 4.6.1 site with debug on.)

    • This topic was modified 3 years, 11 months ago by JordanPak.
    • This topic was modified 3 years, 11 months ago by JordanPak.
Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘Plugin Activation Error(s), Class Constructor, and Missing Activation Button’ is closed to new replies.