Support » Plugins » [Plugin: Absolute Privacy] Error after updating to 2.0

  • Hi,
    I had a problem on two WordPress 3.0.4 installations after updating from Absolute Privacy 1.3 to 2.0:

    The plugin could not be activated because general-functions.php called in line 49 of /wp-content/plugins/absolute-privacy/absolute_privacy.php was missing. Renaming functions.php to general-functions.php in that folder solved the issue, tough, and Absolute Privacy is now running smoothly.

    I’m not a developer so I don’t know if something during installation did not work or anything else – I just thought I’ll post it in case anyone else gets the same error.

    Kind regards,

Viewing 15 replies - 1 through 15 (of 18 total)
  • Hi, I was just preparing a post to the forum here because the same thing has just happened to me. I can’t access my WordPress dashboard now, I only see the error message, and as I know basically nothing about php I was at a loss about what to do. I will search for tips on how to rename php files as even that will be new to me!

    Just to say this worked for me too, and my problem is now solved. Thanks Felix and thanks WordPress Support!

    You’re welcome and thanks for the feedback!

    Felix, and anyone else with the same problem: just one more thing. Have you double checked that your sites are still definitely private? I am not sure mine are after this workaround. Also, I can no longer see a settings option in the plugins section for Absolute Privacy in my dashboard. Am now trying to revert to the previous version of the plugin…

    In my installation, Absolute Privacy is showing up in Dashboard. Doublecheck under Plugins if it really is still activated (due to the error mine was disabled automatically, exposing the site). You should also be able to reach the settings at or change the settings directly in MySQL, but the latter is risky if you don’t know what you’re doing.

    You’re right – if it still doesn’t work properly it probably is best to revert and wait for an incremental update.


    Yes, I’ve reverted to the previous version for the moment, as that feels safer. Hopefully the developer might post a solution or some advice here as I saw he was active on the forum recently. I could neither see the settings in Dashboard in the Plugins section, nor in the Settings area (in v.1.3 there is an Absolute Privacy settings page linked from Settings including the option to lock down the site, but I could no longer see that with v.2.0 and I don’t feel confident editing in php or MySQL).

    Yes, I renamed a file and forgot to update the reference to it. I just updated that. Also, old settings weren’t transferring correctly. I’ll be sending that update in the next 15 min. or so

    Thanks for the fast solution. Just tested the automatic update from 1.3 to 2.0.1 successfully, though the settings still didn’t transfer for me.

    v 2.0.3 should get the settings transferred correctly. You old settings are there. If you upgrade to 2.0.3, add the following to your themes functions.php file:

    delete_option( 'absolute-privacy-options' )

    Then load any page on your blog. Then delete that line from your functions.php file. Then go to your admin page and you should have the option to import your old settings. Users upgrading directly to 2.0.3 won’t have to do this, it is automatic for them, but those who upgraded to 2.0.1 or 2.0 first will have to.

    Not the most graceful plugin release here, but we’ll get it figured out.

    Just FYI, I’ve reverted the stable tag to 1.3. Seem to be a few bugs that I and my beta testers didn’t pick up. I hope to move forward with 2.0.x later this weekend.

    Thanks for the attention to this, John. I’ll keep an eye on this page for further updates before trying to upgrade again.

    Ok, just uploaded v2.0.4.

    Those upgrading from v1.3 will now have their settings transfer over correctly. Included a few other bug fixes as well. Please let me know if you find problems in this release. I appreciate everyones patience and being willing to post your problems in the forum!

    I just upgraded my last never updated WP 3.0.4 install with Absolute Privacy 1.3 directly to 2.0.4 and it now worked with all configs staying where they were.

    In my 2.0.1 install, it always said I should update the database but doing so didn’t have any effect so I deleted the options directly in mysql and did a clean 2.0.4 install. But as fast as the updates came, I hope this was a problem noone else had / will have.

    Thank you, John, for putting such effort into this great and free plugin.

    Hi, I’ve just had another go at updating, this time going straight from v.1.3 to 3.0.4 and although the update worked OK (i.e. I didn’t get the php error as the first time), I still ended up without a private site! There was a message warning me about this at the top of the screen however, saying that I might need to update my database, and a link to more information which gave me an error screen from my hosting provider (I think the link was trying to get me to open function.php or something like that). So once again I’ve reverted to v.1.3 and will wait for more advice…

    Strange. I tried again half an hour later and this time it all worked perfectly. No warning message about perhaps needing to update the database, and the site appears to be private. John, the only thing I still can’t see is the settings page for Absolute Privacy?

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘[Plugin: Absolute Privacy] Error after updating to 2.0’ is closed to new replies.