WordPress.org

Support

Support » Plugins and Hacks » [Plugin: Absolute Privacy] 2.04 not working for Multi-Site

[Plugin: Absolute Privacy] 2.04 not working for Multi-Site

  • I just found out that 2.04 doesn’t work for Multisites. You might wanna consider telling that to users before update it. That way, they won’t have to

    1. Go through the upgrade process,
    2. Manually check through all the sub-sites,
    3. Find out that the private sites are exposed to the rest of the world
    4. Find out that MU sites are not supported in this release
    5. Revert to 1.3
    6. Step 1 & Step 2 again

    That’s what happened to me..

Viewing 1 replies (of 1 total)
  • Plugin Author johnkolbert

    @johnkolbert

    WordPress v1.3 was never tested and never worked properly with multisite installations. That you got it working at all was pure luck. v2.0.x simply prevents any of the code from firing if multisite is detected, as many support requests I got were “v1.3 is not working in my MU installation”.

    That said, I’ve updated the readme with a notice that multisite is not supported so as to avoid any confusion. It should show up on the WP.org page shortly.

    You can remove the multisite checks in v2.0.4 by deleting the following lines in absolute_privacy.php: 59 & 80; and the following lines in functions.php: 95-99;

    Test at your own risk.

Viewing 1 replies (of 1 total)
  • The topic ‘[Plugin: Absolute Privacy] 2.04 not working for Multi-Site’ is closed to new replies.