WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: 2046's Loop widget] call_user_func_array() expects valid callback, function 'sa_r

[Resolved] [Plugin: 2046's Loop widget] call_user_func_array() expects valid callback, function 'sa_r

  • learning22

    @learning22

    I recently installed the Network version of WordPress…so I have another learning curve I just started before installing 2046.

    I installed 2046 through the Admin of the Network and enabled it for across the Network. I received the Error below. So I turned off the enabled across the Network and went to my sub-file domain through its Dashboard and enabled 2046 and received the same Error.

    I’m still learning php so I’m new. I didn’t see what I could repair in the reference file which is also below.

    Looks like a great program. Thank you.

    ( ! ) Warning: call_user_func_array() expects parameter 1 to be a valid callback, function 'sa_register_settings' not found or invalid function name in C:\wamp\www\1-W-D-C\wp-includes\plugin.php on line 403<br />
    Call Stack<br />
    #	Time	Memory	Function	Location<br />
    1	0.0007	144824	{main}( )	..\plugins.php:0<br />
    2	0.0014	148872	require_once( 'C:\wamp\www\1-W-D-C\wp-admin\network\admin.php' )	..\plugins.php:11<br />
    3	0.0029	191976	require_once( 'C:\wamp\www\1-W-D-C\wp-admin\admin.php' )	..\admin.php:13<br />
    4	0.9124	15580328	do_action( )	..\admin.php:111<br />
    5	0.9144	15584752	call_user_func_array ( )	..\plugin.php:403

    Lines 400 to 408

    do {<br />
    		foreach ( (array) current($wp_filter[$tag]) as $the_ )<br />
    			if ( !is_null($the_['function']) )<br />
    				call_user_func_array($the_['function'], array_slice($args, 0, (int) $the_['accepted_args']));</p>
    <p>	} while ( next($wp_filter[$tag]) !== false );</p>
    <p>	array_pop($wp_current_filter);<br />
    }

    Line 403:

    call_user_func_array($the_['function'], array_slice($args, 0, (int) $the_[

    This is on my localhost running WAMP.

    http://wordpress.org/extend/plugins/2046s-widget-loops/

    p.s. Allowed markup allows for use of ‘code’ for formatting and then it says to put code in backticks. Just put both in and now retrying with just backticks.

Viewing 4 replies - 1 through 4 (of 4 total)
  • learning22

    @learning22

    p.s. WordPress version: 3.4.2

    learning22

    @learning22

    I deactivate 2046 and the message no longer appears. Still trying to figure it out.

    Plugin Author 2046

    @o-o

    I’m here finally ..:)
    Sorry for that.. The version 0.254 will get rid of this bug.
    Gime a day…there is one more unresolved question.

    learning22

    @learning22

    Excellent response time. I installed and no problems. Now…I need to learn how to use your program.

    Thank you!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] [Plugin: 2046's Loop widget] call_user_func_array() expects valid callback, function 'sa_r’ is closed to new replies.