Support » Plugins » [Plugin: µAudio Player] uAudio Player not working

  • extracted/copied to plugins directory; enabled plugin; created new link to .mp3 file using the built-in Insert Audio feature in the Write Post GUI. Link is fine. Javascript loads fine for plugin it looks like (javascript includes for both microAudio.js.php and jquery.js.php are present in the source). Switched to the default theme in WP2.5 to make sure it wasn’t a conflict in my theme. Disabled all other 3rd-party plugins. Still no dice.

Viewing 14 replies - 1 through 14 (of 14 total)
  • i’m having the same problem. my link is fine, but the player doesn’t load. it’s as if the plugin isn’t loaded.

    Just updated to version 0.2, which changes how the jQuery parses links on the page. This *should* fix any issues with links not showing up.

    In the event it doesn’t, please include a link to the broken installation and I’ll take a look at it.

    ~ Christopher
    µAudio Author.

    And 0.2.1 (just released) actually addressed the problem in a few missed situations.

    ~ Christopher
    µAudio Author.

    I tried to use microaudio 0.2 and like several others, it had no effect when I enabled it. I am using WordPress 2.5.1 with the default theme. I looked at the ma_head function in microAudio.php and noticed that it adds a script element for the microAudio javascript before jquery. When I placed jquery first, the plugin worked. The jquery script element is not inserted when the “k2” theme is in use, presumably because k2 also loads jquery. Since jwriteclub, the author of microaudio, uses k2, perhaps he didn’t test microaudio much with themes that don’t load jquery, like “default”. In any case, the fix seems to be very simple:

    === modified file 'microAudio.php'
    --- microAudio.php	2008-04-29 21:34:49 +0000
    +++ microAudio.php	2008-04-29 21:37:27 +0000
    @@ -29,10 +29,10 @@
     function ma_head() {
     	$ma_url = get_option('siteurl');
    -	echo "<script type='text/javascript' src='$ma_url/wp-content/plugins/microaudio/microAudio.js.php?siteurl=$ma_url'></script>\n";
     	if (get_option('template') != "k2") {
     		echo "<script type='text/javascript' src='$da_url/wp-content/plugins/microaudio/jquery.js.php?ver=1.2.3'></script>\n";
    +	echo "<script type='text/javascript' src='$ma_url/wp-content/plugins/microaudio/microAudio.js.php?siteurl=$ma_url'></script>\n";
     // Management Page

    Thanks a lot, jwriteclub. This plugin uses the nice 1 pixel out player but doesn’t waste a bunch of space on the page when there are several songs.

    Just after getting 0.2 working, I saw that 0.2.1 had been released. It seems to have the order of javascript loading correct, but doesn’t work for some other reason. The create_player function in microAudio.js.php seems to be missing a closing curly bracket, but even when I add one, the plugin doesn’t work reliably. So, for now I’m going back to my modified 0.2.


    There were a couple of problems in the 0.2 branch, and the 0.2.1 release just made things worse.

    0.3 is out. It has been throughly tested on a range of browsers and OSs.

    Thanks to jonner for pointing out the jQuery order issue.

    ~ Christopher
    µAudio Author.

    I am currently using WP 2.5 and I uploaded and installed the plugin but it is not working.

    I link to an .MP3 file in my media library and after saving and viewing the post it just shows as a link and without the micro audio player showing up.

    Any thoughts? Is it my theme that is messing things up?

    for me, it’s still not working.. 1bit autoplayer works though..


    It might be the theme. I’m looking into it. The JS in the next version is smaller.


    Can you provide me with a link please?

    ~ Christopher
    µAudio Author.

    Mine is not working either. Here is my site:

    Is there a fix? Or am I doing something wrong?


    I know I haven’t responded to messages or made updates for a week or two. I’ve moved to Seattle, and am doing somewhat different work, and between the two haven’t had much time for these projects. I do plan to continue supporting them and release new versions soon.


    Further response forthcoming

    Just a note: This plug in is working for me in IE 6, but not Firefox 3. Is this a known issue.

    I am about as much of a WP newbie as you can be. I installed it today. I am using a shared server plan at media temple, and cannot run WP versions over 2.0., just in case those details are relevant.


    It was a known issue that Firefox 3 was not supported. With the release of 0.5 today, this has been rectified, along with several other little squirrels.

    ~ Christopher
    µAudio Author.

    Looks like it would be great but I was not able to get this plugin to work with WP 2.7.1

    I tried installing 0.6.2, 0.6.1, uninstalled all other plugins, added links to MP3s in posts & pages, used included Jquery, my own jquery, tried adding mAjQ = jQuery` to the top of microAudio.js.php – but nothing seemed to work.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Plugin: µAudio Player] uAudio Player not working’ is closed to new replies.