Support » Plugins » Plug ins won't activate/deactivate

  • For some reason my plugs are not activating and deactivating for me.

    A few days ago I tried to add a plug in. It installed fine and I see it my plug in list, but no matter how many times I tried to activate it, it wouldn’t work.

    I thought this was just something isolated with that plug in, but today I tried to deactivate two different plug ins and that won’t work either. It appears to be loading, but then when the page resolves, it is exactly the same with no change (either activating or deactivating).

    Anyone have any idea what could be causing this? Is there some sort of lock setting I may have on and not realized?


Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugins can just be cranky sometimes – you can try resetting the plugins folder – using FTP, just rename the plugins folder to something else temporarily – that will disable all of them for sure and then change it back. See if that fixes the bad behavior. If not, it’s likely one may be causing problems – so you may need to do the same one by one to find the culprit.

    Ok, I just tried that. Renamed the folder and changed it back. Unfortunately no change to the problem.

    I just talked to my host’s support and we tried a few things. They were able to deactivate individual plug ins for me by changing the plug in name and then changing it back. That basically “broke” the plug in and started it again. But I still can’t manually deactivate that same plug in through WP. So even turning it off and on at the back end as you suggested didn’t solve the problem.

    I also noticed that when I try to activate or deactivate a plug in, I get the yellow box at the top of the page that says Plug In Activated (or deactivated). So WP seems to THINK it is doing something. But when I look at the plug ins themselves, there is no actual change.

    I also tried deleting active plugs in by clicking the box and choosing delete from the drop down. That also didn’t work. So basically anything I try doing manually won’t work.

    FWIW, the plug in that wouldn’t install was WP to Twitter version 2.5.9. I finally just deleted it (which worked b/c it was never “active”). But still none of my other plug ins will work, which presumably they would if that was what had caused the problem. This was the most recent plug in i tried to install and everything was working before then. So either that caused some sort of permanent problem, or something else is going on with wordpress.

    Any other suggestions? All my other plugins have been working fine until now when none of them seem to work.



    I’m having exactly the same problem. Mine started acting up after upgrading WP Super Cache. All my plugins were deactivated and now I can’t activate any of them. I get the yellow bar at the top saying they’re activated, but nothing actually happens.

    Mine suddenly came back after a day or two. I think by that point I had my support folks manually disengage Super Cache (mostly by “breaking” the connection by renaming the plugin on the back end). Then I uninstalled and reinstalled everything. I ended up going with a different caching plug in b/c that really messed me up.

    Good luck and hopefully yours will come back to life soon too.

    I just managed to fix mine by going into PHP My Admin. It reported that the WordPress Options table was corrupt and needed to be repaired. Hit the repair button and all was well.

    Repairing the database worked for me. Thank you for saving me from 100 other things I would have tried first aside from the 50 things I tried before I read your post! You learn something new every day lol. i will be writing an article on this this week.

    Thanks again for the help!

    For the record, I had the same issue with WordPress 3.6.1

    I couldn’t deactivate plugins, it would say it succeeded but the plugin would still be active. The problem went away after I did two things, I’m not sure which helped. I went in to phpadmin and looked at the options table (but did no repair). I also deleted an inactive plugin successfully from the WP admin area.

    After this I was able to deactivate plugins from the WP admin panel properly.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Plug ins won't activate/deactivate’ is closed to new replies.