WordPress.org

Support

Support » Plugins and Hacks » User Status Manager » [Resolved] Plug-in using levels instead of capabilities.

[Resolved] Plug-in using levels instead of capabilities.

  • In the admin using debug mode:

    Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /www/smenet.cloudapp.net/wp-includes/functions.php on line 2923 Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /www/smenet.cloudapp.net/wp-includes/functions.php on line 2923

    Caused by line 86 of start.php, using level 8. Should be changed to something like:

    add_menu_page('Status-Manager', 'Status-Manager', 'edit_users',__FILE__, 'manage_user_user_control');

    http://wordpress.org/extend/plugins/user-status-manager/

Viewing 1 replies (of 1 total)
  • Plugin Author Rahul Balakrishna

    @rahulbalakrishna

    Hello fancyfiber,

    Thank you for your concern, but FYI every plugin is reviewed and the approved and if there is any mistake then we get a reply from them as i got for my first plugin.

    And again I would thank you for showing interest in the plug-in and for appreciate for the concern raised. Will test the above code then will add it to my next version.

    Regards,
    Rahul

Viewing 1 replies (of 1 total)
  • The topic ‘[Resolved] Plug-in using levels instead of capabilities.’ is closed to new replies.
Skip to toolbar