WordPress.org

Support

Support » Installation » Plug in problems

Plug in problems

  • I have recently added two plug ins for wp security and database back up, the message below has ‘arrived’ on home and about page. I don’t want to compromise the security or database by fiddling about. Can you help? Regards Alan Oliver

    Warning: array_key_exists() [function.array-key-exists]: The second argument should be either an array or an object in /home/woodfini/public_html/practicalwoodfinishing.com/wp-includes/widgets.php on line 825

Viewing 7 replies - 1 through 7 (of 7 total)
  • First, disable the new plugins one at a time to see which one is causing the problem.

    I have the some problem, I was try to DISABLE ALL PLUGIN but the error still show up 🙁

    How to fix it?

    internetcashprogram

    @internetcashprogram

    I just commented out since i don’t use side widgets. I deactivated all plugins as well and continued to get an error.

    This helped my situation:

    //if ( empty($wp_registered_sidebars[$index]) || !array_key_exists($index, $sidebars_widgets) || !is_array($sidebars_widgets[$index]) || empty($sidebars_widgets[$index]) )
    	//return false;

    internetcashprogram

    @internetcashprogram

    Sorry… forgot to add the file info where to comment out:
    /wp-includes/widgets.php on line 825

    Jauhari

    @jauhari

    So how to fix it? I need to enable widget on my themes and the problem still appear 🙁

    I solved this problem by clicking “save” on a text widget. Weird. 🙂

    I had the same problem happen to me after I changed the ‘wp’ prefix on all my database tables.

    internetcashprogram’s solution of commenting out the offending line of code worked for me, but I was wondering if there’s another work around for someone who still wants to use side widgets?

    I don’t know any PHP or MySql so I can’t figure it out on my own.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Plug in problems’ is closed to new replies.
Skip to toolbar