Support » Plugin: Better Section Navigation Widget » plug in not working

  • Hi,

    I love your plugin but I discovered that your navigation has disappeared from the page where I am using [better-section-nav exclude=”480,920″ sort_by=”post_name”]

    the plugin has been updated.

    Could you please take a look?

    Thanks,

    Brian

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Here is the main error when I turn wp-debug on:

    Notice: the_widget was called incorrectly. Widgets need to be registered using register_widget(), before they can be displayed. Please see Debugging in WordPress for more information. (This message was added in version 4.9.0.) in /home/mauiceme/public_html/cemetery/wp-includes/functions.php on line 4161

    Could you please let me know where earlier versions of the plugin are archived. Thanks!

    Still a GREAT plugin – very useful!

    Brian

    I sadly have to deactivate the plugin and come up with another solution. Thanks for all your hard work in the past! If you want me to hook it up again for testing let me know – when it’s working it is super useful.

    • This reply was modified 6 months, 3 weeks ago by  bigwavemaui.
    cornershop

    (@cornershop)

    Hi @bigwavemaui

    Sorry to hear it. It’s been quite a busy month and we haven’t been able to provide the support we’d like to. I’ll have our developers take a look at the error you received next week and post any updates here if we have them.

    Best,
    Monica

    I’m afraid we don’t know what would be causing problems; we can copy & paste that shortcode and it works fine (“section nav” shows up at https://wordpress.kenji.cshp.co/blog/better-section-nav-test/). The easiest way to troubleshoot would probably be for you to give us login credentials to your site, but it seems like it’s moot now. The other thing that’d be nice to know is where you entered that shortcode (in a text widget? Content for a particular page?).

    Glad you found it useful when it was working. I hope all’s working out well on your site now.

    Best,
    Monica

    Hi again @bigwavemaui

    We had a “d’oh” moment and realized the shortcode actually wasn’t working, because, the_widget() really was being called incorrectly. We just released a new version of the plugin, 1.5.3, which fixes this issue and which makes the [better-section-nav] shortcode work correctly again.

    Sorry for the confusion. I hope this is still useful for you. Also, thank you for helping us fix it for other users!

    Best,
    Monica

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.