Support » Plugin: Responsive Photo Gallery » Plug-in has no data after domain move

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Weblizar

    (@weblizar_support)

    Hello Herbert,
    we have this feature in other plugins, and working to implement on this plugin also, we’ll update on it soon.
    Thanks.

    @weblizar
    Thanks for the quick response.
    Is there something I can do manualy in the database so it will work. Just as a quick fix?

    Just fixed it myself with a temporary work around.

    In my case grunt wordpress deploy changes the serialised array values on pull_db and push_db, which is good. But in this case there are mulitdimensional serialised arrays used by this plug-in (post_meta -> rpg_all_photos_details) and the main character count is not updated in this run.

    Follow me

    1. Make export from WP Export function -> Responsive Photo Gallery
    2. On new location delete all the galleries
    3. On new location do the import via WP Importer, asign all to correct user
    4. Run search replace with on the post meta table(rpg_all_photos_details), use http://github.com/interconnectit/search-replace-db
    5. Done all galleries are working again.

    If you are moving the database by hand, just use the search replace db tool in the link above. It changes the multidimensional serialised arrays correctly. No need for the other steps.

    Happy moving!

    I am having the same issue. We moved a site from a development domain to the real one and now the pictures are missing from the gallery. When I inspect the elements of the pictures that are missing, I see there are referencing the OLD URL.

    I figured I could do a search and replace on the DB like I always do, but for some reason I cannot find the OLD URL in the database. Are these stored somewhere outside of MySQL?

    Please help! Thanks!

    Eric

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Plug-in has no data after domain move’ is closed to new replies.