Support » Plugin: LifterLMS » Plug in error regarding PHP

  • Resolved jjcarolan


    Hi there,
    I keep getting this error:

    Error: Current PHP version does not meet minimum requirements for LifterLMS.

    I’ve contacted Bluehost and they are running 7.3 on both my main site and subdomain where LifterLMS used to be working.

    Please help, my entire site is down.

Viewing 5 replies - 1 through 5 (of 5 total)
  • jjcarolan


    PS, I get this whether i do a fresh install of the plug in with a zip file OR look it up through wordpress.

    Plugin Author Thomas Patrick Levy



    This sounds very much like your server is *not* on PHP 7.3

    If you’re seeing this when you’re trying to install LifterLMS that means WordPress itself is identifying that your server doesn’t meet our minimum requirements (PHP 7.2 — see more here:

    If this is what’s happening then your host is incorrect and your not actually using 7.3.

    You can double check what’s actually running on your server with the new site health check info report (available in WP core 5.2 or later) by navigating to Tools -> Site Health -> Info and then opening the “server” section.

    Can you help orient me to the error your seeing by posting a screencap and also posting a copy of your WordPress site health check report information (click “Copy site info to clipboard”) on the site health screen I mention above and post that to a service like pastebin and paste that link here for me to review.


    I have the same thing, I am on free x10hosting and there the highest ver is 7.1 Can you guys please let others use and test your cms on free hostings with lower phps?

    Plugin Author Thomas Patrick Levy



    You can install the zip file manually to bypass the version requirements enforced by LifterLMS and WordPress on the plugins installation screen.

    Download the zip via the “Download” button on the plugin’s repository and then install it manually via Plugins -> Add New

    LifterLMS does *technically* run on PHP 7.1 but we’re aiming to only support versions of PHP under active support and development. PHP 7.1, for example, is only receiving security releases and will reach its end of life in December (

    If you encounter any issues as a result of using PHP 7.1 we’ll likely ask you to upgrade instead of fixing it for 7.1 users as we officially do not support it so do this at your own risk.


    Thank you for the work around, I will try to do it and report back in a couple of days

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.