Support » Plugin: Polylang » pll_language cookie setting wrong language

  • Resolved mtlsam

    (@mtlsam)


    I’m experiencing a weird issue with Polylang. I have a English + French site, my default language is set to English, but when I visit the root url it takes me to the French homepage.

    What’s configured:

    – Two languages, English being set to default (star icon) with an order value of 0, French is not set as default and has an order value of 1.
    – My homepage and all other pages have English and French versions, and are correctly linked together.
    – My home URL is set to my English homepage in Settings -> Reading (static page, not latest posts.)
    – My administrator user account has the language setting set to “site default” in the Users -> Profile settings.

    Yet when I’m logged into my administrator account and visit the homepage it takes me to the french URL and I can see in my Chrome developer tools that the pll_language cookie is set to “fr”.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Thread Starter mtlsam

    (@mtlsam)

    Detect browser language is also off, and my browser is set to English anyways. I’ve tried things like clearing cache and deleting cookies, as well as re-saving permalinks and settings.

    • This reply was modified 1 year, 6 months ago by mtlsam.
    Thread Starter mtlsam

    (@mtlsam)

    Issue was seemingly caused by Windows and/or Chrome settings that got changed on my device somehow.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘pll_language cookie setting wrong language’ is closed to new replies.