Support » Plugin: Restricted Site Access » Plesk Smart Update

  • Resolved wildlifeworld

    (@wildlifeworld)


    Hi Jeff and team,

    I am managing a few WordPress sites for my employer and due to the ‘plug-in soup’ I have inherited on most of them and the stress it causes wondering if I am going to bring a site down, I bought the Plesk Smart Update extension. It clones the WordPress site, installs all the theme and plug-ins you select and shows you a before and after snapshot and runs some sense checks which gives me the confidence to hit the update button without the hassle of running a parallel staging site.

    It generally works great, apart from on the site we use ‘Restricted Site Access’ on! I reckon it’s a htaccess/rewrite rules issue as described here on the Plesk site.

    I’m no developer though sadly, I wonder if you could confirm I am on the right track? Or even better, suggest a workaround that might enable me to keep this site up to date and get more restful sleep!

    Thanks,
    Paul

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Tung Du

    (@dinhtungdu)

    Hi @wildlifeworld, I don’t have experient with Plesk Smart Update so I can’t confirm the direction you mentioned.

    IMO, you should contact the support team to see if you can exclude some specific plugins from the update test (in this case, it’s RSA).

    Hope that helps!

    Thread Starter wildlifeworld

    (@wildlifeworld)

    Thanks Tung, it’s the cloning of the site that fails (the updates run fine). So that’s why I am speculating that it’s htaccess/rewrite rules from RSA causing the issue.

    I’ll have a look at the source code and see if I can work it out if one of your devs can’t give me any pointers.

    Plugin Support Tung Du

    (@dinhtungdu)

    > So that’s why I am speculating that it’s htaccess/rewrite rules from RSA causing the issue.

    FYI, RSA doesn’t add any htaccess/rewrite rule. RSA hooks to parse_request action to restrict the access of visitors based on IP address.

    Thread Starter wildlifeworld

    (@wildlifeworld)

    Thanks @dinhtungdu – ahhh perhaps there is an IP address of the SmartUpdate server that I can whitelist. Thanks for confirming RSA doesn’t add htacess/rewrite rules.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Plesk Smart Update’ is closed to new replies.