Support » Plugin: SuperSaaS - online appointment scheduling » Please update the coding to current standards.

  • This plugin is still using a function that has been deprecated since WP 4.5.0 was released on April 12th, 2016. So that is now more than 3 years ago. 😉

    Please replace /includes/shortcode.php line 17 from
    get_currentuserinfo(); to the correct wp_get_current_user();

    The use of this old function floods error logs.

    Also, it is not unlikely that after a certain period WordPress will remove get_currentuserinfo(); all together – breaking the plugin.

    Also, line 40 in that same file gives a PHP warning:
    Undefined index: HTTP_X_FORWARDED_PROTO in /wp-content/plugins/supersaas-appointment-scheduling/includes/shortcode.php on line 40

    Could you please correct these and release an update?
    Thank you! 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Please update the coding to current standards.’ is closed to new replies.