Support » Plugin: GravityExport Lite (Gravity Forms Entries in Excel) » Please update PHP version minimum requirement to 7.3

  • Resolved KZeni

    (@kzeni)


    The WP.org info for this plugin says PHP 7.1 or newer is supported. However, the file at vendor/composer/platform_check.php throws an error when the plugin is activated on a setup using PHP older than 7.3.

    As such, the WP.org info should be updated to require PHP 7.3 or newer to prevent issues & make it so sites not yet on 7.3 don’t try to upgrade to a version that doesn’t work for them.

    Otherwise, the PHP version check for composer needs to be updated to be 7.1 if that check is actually more aggressive in the required PHP version that it needs to be. Side note, commenting out where it sets the issue for the PHP version in vendor/composer/platform_check.php on a site with PHP 7.2 isn’t showing any immediate issues, if older PHP version compatibility is still needed.

    Thanks for the great plugin & hopefully this is a reasonable request!

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.