WordPress.org

Support

Support » Requests and Feedback » Please update minimum requirements

Please update minimum requirements

  • Please can someone revise the Requirements page urgently:

    http://wordpress.org/about/requirements/

    Currently it only states the Minimum Requirements – which are PHP version 4.3
    and MySQL version 4.1.2

    Would it not be better to give the recommended requirements instead?

    According to this statement from WordPress published six months ago:

    PHP 4 and MySQL 4 End of Life Announcement

    – WordPress will soon be abandoning support for PHP 4 and MySQL 4.

    I know the new versions haven’t rolled out as quickly as this document predicted but it could be just a couple of months before version 3.2 comes out which will only work using PHP 5.2 or higher and MySQL 5.0.15 or higher.

    Also, a lot of current plug ins only work with PHP 5 – so the version you suggest isn’t even right for the time being.

Viewing 4 replies - 1 through 4 (of 4 total)
  • mrmist

    @mrmist

    Forum Janitor

    It’s correct as it stands though. Plugins have their own requirements. I suspect it will change closer to the 3.2 time.

    Yes, its technically correct for WordPress alone, but who uses WordPress without any plug-ins?

    Why advise people who are setting up a new deal with their host to request requirements which already don’t work for a lot of plugins and which will prevent updating to WordPress 3.2 in, perhaps, just a couple of months?

    Why not simply say:

    WordPress recommends PHP 5.2 or higher and MySQL 5.0.15 or higher?

    – then mention the minimum requirements in the small print with a warning that not all plugins will work with the minimum requirements …

    esmi

    @esmi

    Forum Moderator

    As far as I recall, the minimum requirements are reviewed at regular intervals and that last time it was discussed, it was decided that PHP4 will still be supported. And these are minimum – not optimal requirements.

    Yes I know they are minimum requirements but they are also presented as optimal instructions to send to the host:

    I’m interested in running the open-source WordPress <http://wordpress.org/&gt; blogging software and I was wondering if my account supported the following:

    PHP 4.3 or greater
    MySQL 4.1.2 or greater
    The mod_rewrite Apache module
    Thanks!

    My point is, why not give the host optimal requirements instead? After all, the majority of hosts these days will be able to provide PHP 5.2 or higher and MySQL 5.0.15 or higher. So why ask for less?

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Please update minimum requirements’ is closed to new replies.
Skip to toolbar