WordPress.org

Support

Support » Plugins and Hacks » Please test File Gallery 1.7.5

Please test File Gallery 1.7.5

  • I’ve uploaded version 1.7.5 to trunk – you can download and test it from here:

    http://downloads.wordpress.org/plugin/file-gallery.zip

    If no one reports and weird stuff, I’m going to push it to stable tomorrow evening 😉

    == changes since 1.7.4.1: ==

    * June 17th, 2012
    * bugfix: php error because of referenced variables (thanks kraterdesign!)
    * bugfix: php error on media settings page when a value
    contains a single quote (thanks crmart, grollaz, amandajoonline!)
    * Advanced Custom Fields compatibility fix (thanks serdominik!)
    * some new and some improved translations
    * moved debug info to Debug Bar plugin
    * minor adjustments in default and simple templates
    * bunch of minor fixes, as always

    = 1.7.5-beta-2 =
    * March 10th, 2012
    * bugfix: internet explorer – tinymce focus on insert
    * moved tinymce-related code into a tinymce plugin
    * media listings page – regenerate single image link
    * drag and drop upload to file gallery box
    * insert a tag gallery without any files attached to a post
    * post thumb on post listing screen – on click open thickbox
    with bigger image
    * add “change” link to media tags name and slug on media
    settings page

    = 1.7.5-beta-1 =
    * February 26th, 2012
    * added “change” links to media tags name and slug on
    media settings page
    * post thumb on post listing screen now opens a thickbox
    with the bigger image when clicked
    * ability tp insert a tag gallery without any files
    attached to a post
    * tweaked drag and drop upload to file gallery box a bit
    * bugfix: internet explorer insert content position
    (adds a bookmark on mouse up)
    * added Arabic translation by Wassem Mansour (thanks!)

    http://wordpress.org/extend/plugins/file-gallery/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Hi,

    I do have a small problem with “prettyPhoto” and the “simple template”

    I installed prettyphoto without a plugin with this code

    /****** PrettyPhoto *******/
    add_action('wp_enqueue_scripts', 'wdm_scripts');
    function wdm_scripts() {
        wp_deregister_script('jquery');
        wp_register_script('jquery', "http" . ($_SERVER['SERVER_PORT'] == 443 ? "s" : "") . "://ajax.googleapis.com/ajax/libs/jquery/1.7.2/jquery.min.js", false, null);
        wp_enqueue_script('jquery');
        wp_enqueue_script('pretty', get_stylesheet_directory_uri().'/custom/js/jquery.prettyPhoto.js', array('jquery'), '3.1.4', false);
        wp_enqueue_style('pretty', get_stylesheet_directory_uri().'/custom/css/prettyPhoto.css', false, '3.1.4', 'all' );
    }
    
    add_action('wp_head','wdm_theme_head');
    function wdm_theme_head() { ?>
    <script type="text/javascript">
    (function($) {
        $(document).ready(function(){
            $("a[rel^='prettyPhoto'],a[class^='prettyPhoto']").prettyPhoto();
        });
        });
    })(jQuery);
    </script>
    <?php }

    It works great no problems on individual images, BUT using the shortcode [gallery size="medium" link="file" link_size="large" linkclass="prettyPhoto" galleryclass="prettyPhoto" template="simple"]
    the images are shown just next to each other, the simple gallery layout
    is ignored, but the prettyphoto works upon clicking on the images,
    iam using the latest wordpress version and the new File gallery 1.75

    I think the problem is that the JS
    …wp-content/plugins/file-gallery/templates/simple/gallery.js?ver=1.7.5 is not loaded …. any ideas

    Hi,

    now I managed to load the javascript with

    <script type="text/javascript" src="<?php bloginfo('url'); ?>/wp-content/plugins/file-gallery/templates/simple/gallery.js"></script>
    <script type="text/javascript" src="<?php bloginfo('url'); ?>/wp-content/plugins/file-gallery/templates/simple/gallery.css"></script>
    <script type="text/javascript" src="<?php bloginfo('url'); ?>/wp-content/plugins/file-gallery/templates/simple/gallery.php"></script>

    still doesn’t work

    Plugin Author Aesqe

    @aesqe

    @diver66: I’ll test it and report back a bit later today.

    thats very kind of you

    thanks you

    Plugin Author Aesqe

    @aesqe

    @diver66: you have an error in your javascript code:

    });
        });
    })(jQuery);

    should be

    });
    })(jQuery);
    Plugin Author Aesqe

    @aesqe

    also, you should move that whole piece of javascript to wp_footer, so it fires after the simple template javascript, like this:

    add_action('wp_footer','wdm_theme_head', 1000);

    and remove those script tags you’ve added manually.

    then download the newest dev version of the plugin (1.7.5.1) from here – http://downloads.wordpress.org/plugin/file-gallery.zip (same link as before, but updated file).

    let me know if it works! 🙂

    Hi Asque,
    I followed your advice and it didn’t work, but if it works okay and you tested it, it must be something on my side that is not correct,

    I then desinstalled the plugin AND ticked the box that says ” delete options on deactivate” … deinstalled and deleted the directory … reinstalled and voila it worked, I tested this with 1.7.4 then update to 1.7.4.1 then deleted options again and installed 1.7.5.1,

    Basically that means that something went wrong updating the plugin, which prevented the template “simple” to work. I am glad we got this sorted out, thank you very very much for your time and effort.

    Plugin Author Aesqe

    @aesqe

    @diver66: glad to hear it works now 🙂

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Please test File Gallery 1.7.5’ is closed to new replies.