Support » Plugin: PhastPress » Please Suggest Optimization

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author Albert Peschar

    (@kiboit)

    Hi @syamsq,

    PhastPress’ CSS and JS optimization isn’t working because CSS and JS files are loaded from a separate domain (cdn.yourdomain.com). You should disable this first so that CSS and JS files can be bundled and optimized by PhastPress.

    After that, I can have another look to see if anything else should be improved.

    –Albert

    Thread Starter SyamsQ

    (@syamsq)

    Ok, I have just disable it. Please suggest me.
    DIsabled JS and CSS

    Thread Starter SyamsQ

    (@syamsq)

    Hi @kiboit

    I have exclude Js & CSS.

    Plugin Author Albert Peschar

    (@kiboit)

    Hi @syamsq,

    Sorry, I wasn’t able to get back to you earlier.

    It looks like you have now disabled PhastPress optimizations for JS and CSS as well. You should turn those back on, if you want your JS and CSS load to be optimized.

    –Albert

    Thread Starter SyamsQ

    (@syamsq)

    Hi @kiboit
    I think it always enable. I never disable PhastPress optimizations for JS and CSS
    https://i.postimg.cc/W33r647k/screenshot-1067.png

    Plugin Author Albert Peschar

    (@kiboit)

    Hey @syamsq,

    It turns out that PhastPress did not work yet with LiteSpeed Cache.

    I’ve just released PhastPress 1.95 to fix this issue. Could you update to this new version, and let me know?

    –Albert

    Thread Starter SyamsQ

    (@syamsq)

    Yes, I done, please check it.

    • This reply was modified 10 months, 1 week ago by SyamsQ.
    Plugin Author Albert Peschar

    (@kiboit)

    Hi @syamsq,

    Thank you! It turns out there’s another issue with your site. The page you linked is very big because of all the comments. PhastPress has a limit for the maximum page size for optimization. This limit was 1MB and your page is slightly larger.

    I’ve now released PhastPress 1.96 with an increased limit of 2MB.

    Can you update to this new version and let me know again? Thank you.

    –Albert

    Thread Starter SyamsQ

    (@syamsq)

    I done, Anyway thanks for support.
    What’s next?

    Plugin Author Albert Peschar

    (@kiboit)

    Hi @syamsq,

    No problem. You helped me discover some bugs in PhastPress that I’m glad to fix.

    Now it seems PhastPress is working well on your site. The main page now loads with just 12 requests:

    GTmetrix before and after:

    PageSpeed Insights scores seem to actually be lower with PhastPress, even though the page renders faster. It looks like the main thing slowing down the site is the Google AdSense. There’s not much you can do about that, I’m afraid.

    I don’t have any further suggestions for optimizing your site.

    –Albert

    Plugin Author Albert Peschar

    (@kiboit)

    Oh, I have one suggestion for the articles. The one linked has so many comments that the page gets really big. If you break the comments into multiple pages, or use a lazy loading plugin, the page will load a little faster.

    See this article: https://kinsta.com/blog/wordpress-comments/

    –Albert

    Thread Starter SyamsQ

    (@syamsq)

    I think PhastPress prohibits Lazy Load feature, so I disable it. Then, Do i need enable LSCache’s Lazy Load ?

    • This reply was modified 10 months, 1 week ago by SyamsQ.
    Plugin Author Albert Peschar

    (@kiboit)

    Hi @syamsq,

    I think you need only PhastPress’ lazy load functionality.

    If LSCache lazy load works better for you, just disable PhastPress lazy loading.

    I would recommend using PhastPress lazy loading.

    –Albert

    Thread Starter SyamsQ

    (@syamsq)

    Thank’s a lot for your help.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Please Suggest Optimization’ is closed to new replies.