• Resolved macaraigmichelle

    (@macaraigmichelle)


    Hello, for your assistance please.

    Members are unable to register when selecting a role, there’s an error: “Please specify account type” even if the role is already selected. The error started after 2.1.11 update

Viewing 12 replies - 1 through 12 (of 12 total)
  • Thread Starter macaraigmichelle

    (@macaraigmichelle)

    Hi Ultimate Member support, any update please?

    I am also having this error on my website as well – I would like an answer from Ultimate Member if possible too.

    The issue seems to be with the default registration form (but not sure if it affects custom forms) and the options for accounts. My issue may be more complicated because I have TWO user account types as “Customer” because the Ultimate Member plugin added a “um_customer” to WordPress despite the fact that I already had a “um_customer” account type already available. So I have TWO “customer” account types and I feel that may be adding to the problem as well.

    The difficulty with that is that I cannot delete either account type because when I do, it ALWAYS removes the one I did not create instead of the one I did no matter which one I delete, and that screws up every single account (all 700+) on my website with that account type assigned.

    HELP!

    Agreed, I am having the same issue. I have had to roll back to a previous version to get things to work again.

    Plugin Contributor Champ Camba

    (@champsupertramp)

    Hi @xfire0384 @rzalexander @macaraigmichelle

    I’m currently investigating this issue.
    I tried adding a role field in the UM Register form and it works on our end. Could you please provide a video clip so I can see the issue clearly?

    Regards,

    @champsupertramp Here you go. I noticed it on the profile edit page. Sorry for how slow the pages load, I took the video from a staging environment as I had to roll back my production site.

    Still having the same issue as before. When a user tries to register for access to our website, they see “Please specify account type.” You can try it yourself here:

    https://support.statussolutions.com/register

    This happens for every user role that is selected. I have replaced the default registration form and it still does the same exact thing. I need this to be fixed and would be happy to pay for the Premium version if that will resolve my issues faster. Please see the video below.

    https://videos.sproutvideo.com/embed/709cd7b91e1fe2c3f9/d101dde1865456a2

    EDIT: I have temporarily rolled back my version of Ultimate Member to 2.1.10 and that has temporarily fixed the issue. Registering for access to our website will not reproduce this error any longer, but the video above shows the behavior. If someone is able to work with me on this, I can show you what happens with version 2.1.11

    • This reply was modified 1 year, 8 months ago by rzalexander.
    • This reply was modified 1 year, 8 months ago by rzalexander. Reason: rolled back my version of the plugin

    I’m having this same error on https://pinnacleone.solutions/register/

    I recorded a video of the error here: https://www.loom.com/share/392022c315bb412fbab9753696c5def4

    @champsupertramp

    • This reply was modified 1 year, 8 months ago by Joel Jones. Reason: Tagged @champsupertramp

    Any update on this?

    Plugin Contributor Champ Camba

    (@champsupertramp)

    Hi Everyone,

    Could you please try this pre-release version in the link?
    https://drive.google.com/file/d/1-6jx7D2I2BNqdWc04FqSRYXP-dTx08pb/view?usp=sharing

    We’ve made changes to fix the issue.

    Ensure that you’ve created a full backup of your site before you do the update.

    Let us know if the fixes resolve the issue.

    Regards,

    That update fixed my issue, Champ. Thank you for providing this!

    Plugin Contributor Champ Camba

    (@champsupertramp)

    Hi @rzalexander

    Thanks for letting us know.

    I am closing this thread now.

    Regards,

    Sorry for the late reply. I seem to still be getting the same issue as in my video above after downloading and copying over the files for the update from your Google Drive link.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Please specify account type’ is closed to new replies.