Support » Plugin: Black Studio TinyMCE Widget » Please remove z-index 100000 !important

  • Resolved FriendlyWP

    (@mmcginnis)


    Hi! I love your widget – thanks so much for the plugin! Quick request (I hope) – can I beg you to remove your z-index:100000 !important on your widget-item in the control panel? that’s super-high and overrides most other widgets. If I’m on a laptop screen and ‘open’ a widget placed in a sidebar to edit its contents, I still see the “Visual Editor” widget-box from the Available Widgets area placed on top of it, for instance. Super annoying.

    In my tests changing it to z-index:100 or even z-index:100 !important fixes it. ??

    Thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Marco Chiesi

    (@marcochiesi)

    Hi there,
    the rule z-index: 100000 !important; was recently added to fix an issue with WP main admin menu (see this topic).
    Unfortunately it’s pretty hard dealing with z-index on WordPress admin as there are many elements coming from different sources, and fixing an issue could cause a different issue elsewhere.
    Please could you provide additional information about the specific issue you observe? I.e. screen resolution, widgets/plugins you’re using, screenshots…
    Thanks.

    Hi again, sure thing. I’m using Chrome 71.0.3578.98 on PC, window size about 1000px
    by 650px tall (large enough to get the left control panel menu showing). Go to Appearance > Widgets and scroll down enough to see “Visual Editor” in the Available Widgets area, then hover over something in the left control panel menu with a flyout – like “Settings”. The flyout menu appears but the Visual Editor available-widget is stuck on top of it so you can’t see the full Settings flyout menu.

    Same thing happens for any widget you open in the Sidebars that has enough height/width to cover the Visual Editor ‘available widget’ block at the left. Hope that helps, thanks again!

    Plugin Author Marco Chiesi

    (@marcochiesi)

    Thanks for the detailed report.
    The issue has been fixed in version 2.6.7.
    Now that rule is applied only when the widget is open.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Please remove z-index 100000 !important’ is closed to new replies.