Support » Plugin: Contact Form 7 » Please remove span wrapping !

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Takayuki Miyoshi

    (@takayukister)

    The problem is not CSS, the problem is your span wrapping !

    Re-read my message. It’s impossible, for now, to style label when input is focused because you wrap input in span.

    <span><input></span><label>

    In CSS3, you can’t reach <label> when <input> is focused.

    *bump*

    At the moment this problem is not solved and it is really necessary to provide a semantic and mindful markup.

    Please remove the spans around form elements so that the label can be addressed by CSS. Or at least tell us, what’s the idea behind this markup.

    If your in trouble with time, please provide information about contributing.

    Tanks.

    +1 on that one.
    Adding a filter to the fields output would be great.

    I too have had issues with this. I am unable to use selectors like +, ~, or > because the <span> wrappers. Is there anything at all that we can do to remove these? Please don’t just link to “Styling Contact Form”.

    Thanks

    YES, please remove the <span> wrappers! What a headache it is when stuff like that is added automatically. If I wanted wrappers I’d put them in the plugin backend like all the rest of the form code. Is there any sort of possible timeline for this for a future update? Or is there a way to unhook that now?

    Hey all,

    If you’re using jQuery, here’s a solution that I’ve gotten working. Please note though that apparently the validation errors for the individual fields (“Please fill the required field” etc.) require the span wrap, so those don’t show up. The error at the bottom still does though.

    <script>
     $(document).ready(function(){
         $("input.customclass").unwrap();
     });
     </script>

    Just add a custom class to the inputs that you don’t want wrapped.

    Yes, please!
    Also the br line breaks.

    • This reply was modified 1 year, 1 month ago by  tatsumisuzuki.

    Same here, I’ve also had issues with the span wrapping. Please, remove the wrappers!

    Aminta

    (@aminta)

    I would add to earlier requests, please remove the <span> tag, and thanks for your wonderful plugin!

    niaccurshi

    (@niaccurshi)

    Yes, please, at least allow for a checkbox or something to not add all this extra mark up. I don’t need the plugin presuming that I need spans or paragraphs or breaks!

    I have edited this <span class="wpcf7-form-control-wrap %1$s"><input %2$s />%3$s</span> to <input %2$s /> in modules/text.php and span

    • This reply was modified 10 months, 2 weeks ago by  .

    Bump, good work on the plugin but are you planning to honor this request?

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Please remove span wrapping !’ is closed to new replies.