WordPress.org

Support

PLEASE READ ME BEFORE POSTING!

Viewing 15 replies - 1 through 15 (of 15 total)
  • Is there a way to control the layer order of the pins on the map? For instance, if I want a pin be placed on top of the other pins to stand out.

    Plugin Author RobertHarm

    @harmr

    currently not, but will be included in the pro version (not with v1.0, but definitely later)

    Hello Robert, this is really a great plugin, more advanced and easier to use than any other map plugin I could find. All is working well on my WPMU site. No issues at all. As I am new to this mapping stuff I have a question/request. I would like to show maps/layers created on site 1 on site 2. I have 2 different WPMU 3.5 sites and would like to show the same maps on both. I read the jason info but it is over my head. Please could you point me in the right direction to more info about this? v3.4.3

    Pro version would be nice, count me in.
    Kelly

    Plugin Author RobertHarm

    @harmr

    Hi Kelly,
    Support for GeoJSON is planned for pro version.
    Regards
    Robert

    Hello again Robert
    Thanks for the plugin. I am using it with every post of my blog. I tried adding a bookmark to two or more layers, but I think it is impossible. I’ll have to duplicate all the markers that appear in small layers to manage a large map with all markers. Perhaps it would be great if all the global map was not considered as a layer … Is this possible?
    Thanks, Juanlu

    Mapa RojiVerde

    Plugin Author RobertHarm

    @harmr

    Hi Juanlu,
    please switch to advanced editor, then create a new layer and select the checkbox “Multi layer map”. You can then choose which layers you want to have displayed on this map (either all markers or markers from selected other layers). Hope this solves your issue.
    best,
    Robert

    PS: as I give support for free, I´d appreciate your review at http://wordpress.org/support/view/plugin-reviews/leaflet-maps-marker

    Thanks Robert, problem solved and review done.
    Best wordpress plugin… sure

    Hello. I have more than 400 layers on my site and when I choose (in my multi layer map) about 100 layers, only about 60 layers are shown. The rest that I’ve checked in the checkboxes are unchecked and not shown. Is that a limit i can do something about?

    Plugin Author RobertHarm

    @harmr

    the IDs of the layers for a multi layer map are stored in the table wp_leafletmapsmarker_layers, row multi_layer_map_list. This field is varchar(255) – didnt set it higher as a higher memory means more RAM usage…

    changing would be easy:
    1. make a backup of your tables
    2. execute this SQL query via phpmyadmin:

    ALTER TABLE 'wp_leafletmapsmarker_layers' CHANGE 'multi_layer_map_list' 'multi_layer_map_list' VARCHAR( 1000 ) CHARACTER SET utf8 COLLATE utf8_general_ci NULL DEFAULT NULL

    3. edit /inc/install-and-updates.php and set line 88 to
    multi_layer_map_list varchar(1000) DEFAULT NULL,

    updating to a newer version would be harder though: as I dont plan to change this datatype, you would have to download the zip package of a new version manually and repeat step 3 before manually updating to the new version by uploading the files via FTP.
    Automatic update would set back the datatype to varchar(255) and thus eventually cut off values which were larger than this.
    best,

    Robert

    Hi Robert,
    Thank you for developing such an awesome plugin. Can’t wait until the Pro version comes out.

    I am using a premium WP theme and can’t figure out why my markers are not showing on the map. They are there in full screen mode but not on the page. I even viewed code and manually added links to leaflet.css and leaflet.js right before closing the <head> tag. Still no love. I’m probably missing something simple but I’m already beating my head against the wall. Please, please take a look if you have a chance. I would really appreciate any guidance or advise if possible. You can see those markers not showing up at: http://bit.ly/18xpwlW

    Thanks again

    Plugin Author RobertHarm

    @harmr

    have you already followed the steps from http://mapsmarker.com/readme-first already?

    Yes, I did.
    The markers show up when If I set the theme to Twenty Twelve.
    I can’t figure out why it is not working with the premium theme though. I have minimum plugins installed.

    Plugin Author RobertHarm

    @harmr

    Hi pilichev,

    the problem is within the css from your theme:

    .main-content img {
    ...
    max-height:100%
    ...
    }

    is causing the marker to disappear…
    best,

    Robert

    That did the trick. Now the map works like a charm.
    Thanks again for the outstanding support and your awesome plugin!
    (Also rated and donated)

    Plugin Author RobertHarm

    @harmr

    thx

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘PLEASE READ ME BEFORE POSTING!’ is closed to new replies.
Skip to toolbar