Support » Plugin: Quantities and Units for WooCommerce » Please match the requested format error

  • Hi,

    I am using the latest versions of both Commerce and WordPress. Did a fresh install of this plugin and without any inputs, I get an error across all products: Please match the requested format error. This happens when someone tries to add to cart.

    Please let me know if anyone is also experiencing this and if you can help. I did a search on this support forum and it seems that I am the only one experiencing this.

    Thank you for your support,
    Francisco

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hi I’m having the same problem did you find in the course of waiting for the answer a solution?

    Thank you for your support,
    ITfriend

    Plugin Author Nick Verwymeren

    (@greatwitenorth)

    Usually I see this error popup with certain themes. Have you tried switching the theme to see if the issue still happens?

    Hi Nick,

    You are right, this is related to the theme. I am using Enfold.

    I understand if you can’t help any further but let me know if, from your experience, you can point us in the right direction in order to fix this.

    Thanks,
    Francisco

    Hi Nick, In my case I canĀ“t change the theme there’s something that I can do to fix this?
    And By the way when I create Rule to a Category it gets pendent for acceptance who’s suppose to accept the rule in order to get working?

    Thanks for the attention
    ITFriend

    Hi. I had the same problem. Problem is that input field has pattern value empty, but has the attribute. Solution is to remove this attribute. I’ve solved it editing /asstets/js/ipq_input_value_validation.js
    Find jQuery(document).ready( function($) { and after it paste this lines:

    if ($('.qty').attr("pattern") == ''){
    	$('.qty').removeAttr("pattern");
    }

    This must solve your problem. I sugest to solve it in the pluggin.
    Regards

    @arminet, your tip totally solves the problem!
    As you say, it should be solved on the plugin distribution.
    I have specific question: I am based in argentina where we use comma to separate decimals and point to separate thousands.
    The plgin does not even allow me to state a comma for separating decimals. Any idea on how it could be done? Thanks!!! U rock

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Please match the requested format error’ is closed to new replies.