Please help - think I have a htaccess-problem (2 posts)

  1. chrislea
    Posted 3 years ago #

    Please help me out - I have installed multisides - subdomains and followed every instruction in the book - and all I am getting is a 404 error on new sites?

    I want to create an extra site that is 100% separate, no shared content and with different theme settings, so I think It I am on the right path choosing multisites.

    It is truly driving me insane...

    My config.php add in looks like this:

     * For developers: WordPress debugging mode.
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
    define('WP_DEBUG', false);
    /* Multisite */
    define('WP_ALLOW_MULTISITE', true);
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', true );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'kamber.dk' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );
    define( 'SUNRISE', 'on' );

    My .htaccess looks like this:

    # -FrontPage-
    <Limit GET POST>
    order deny,allow
    deny from all
    allow from all
    <Limit PUT DELETE>
    order deny,allow
    deny from all
    AuthUserFile /home/dkkamber/public_html/_vti_pvt/service.pwd
    AuthGroupFile /home/dkkamber/public_html/_vti_pvt/service.grp
    DirectoryIndex index.htm Index.htm index.html Index.html index.php Index.php default.htm Default.htm Welcometocarlsonnet.htm
    # Always use www in the domain
    # Replace 'example.com' with your domain name
    RewriteEngine on
    RewriteCond %{HTTP_HOST} ^([a-z.]+)?proevekunde\.dk$ [NC]
    RewriteCond %{HTTP_HOST} !^www\. [NC]
    RewriteRule .? http://www.%1proevekunde.dk%{REQUEST_URI} [R=301,L]
    AuthName kamber.dk
    IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti*
    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    # END WordPress

    And I have added a blogs.dir directory in the wp-content folder and checked that it has the right settings.

    I have also added an a-record *.kamber.dk through the advanced DNS settings in C-panel.

    Can anyone locate, what is missing? I have a strong feeling, that it might have something to do with my htaccess file?

    Please help me, as I have a dealine coming up very soon.

    Thank you soooo much for your support in advance.

    Kind regards Chrislea (Denmark)

  2. Step 1) Strip .htaccess down to JUST wordpress.

    How's that work?

Topic Closed

This topic has been closed to new replies.

About this Topic