Please Help - Site Redirect not working correctly (5 posts)

  1. matthewhearsum
    Posted 4 years ago #

    I hope someone can help me.

    I had a wordpress.com hosted site (Old Site), and have now moved to a self-hosted site (New Site). I bought the site redirect upgrade, but it's coming out with gibberish.

    For exammple, the permalink for one page on both the old site and the new site is


    However, when I perform a google search for this page (it is number 1 in teh rankikngs for "kaye v lawrence") it gives the following as the URL


    which results in a 404 error equivilent.

    I've checked to make sure the permalink structure is the same on both sites, and that all the old posts exists on the new site, but no joy.

    Any ideas?

  2. Pioneer Web Design
    Posted 4 years ago #

    Google is not listing the redirect but the actual pages or posts of your site and the currently output url which is in the form:


    The Slug appears to be corrupt, contains extra white space or hidden characters...Or, your sitemap is listing the actual URL wrong...

    To fix, edit the page and manually and correctly retype (do not cut and paste) the slug and if using a sitemap retype there also.

    If using a sitemap, manually resubmit your sitemap using Google Webmaster Tools and give it the time required to re-index and re-list your site.

    I would also review if using a SEO plugin if that might be the issue.

  3. matthewhearsum
    Posted 4 years ago #

    Firstly, my apologies for the spelling in my post - it was quite late at night!

    Thansk for your help Seacost. The old site does not use a sitemap (the new one does) and the old site does not use an seo plug-in (the new one does).

    I've tried re-typing the permalinks but no success.

    I've tried typing the permalinks manually into the URL bar and it links through fine, so the problem appears to be the way google picks up the redirected permalink - you're right, it adds some strange characters to the slug. In particular:

    It replaces a dast with "-%E2%80%93" on one occasion or with "%C2%A0" on two further occasions.

  4. matthewhearsum
    Posted 4 years ago #

    OK, new development.

    It seems that the one post I chose to test this with is the only post that has this problem; that is, all of the other posts are fine. Just another example of my bad luck I suppose!

    Not sure why it is just that one post. Any ideas?

  5. matthewhearsum
    Posted 4 years ago #

    Further update.

    It seems that the problem is with Google - they have recoded the link to the old site post with the gibberish characters. It seems to work for Google, bit will not work when I try and use them for the slug in old site or new site.

    I have submitted a request to Google to re-index the link and we'll see what happens. In the meantime any other ideas would be gratefully received.

Topic Closed

This topic has been closed to new replies.

About this Topic