Support » Fixing WordPress » Please help me get rid of these Â

  • I am using wordpress 2.7 and recently started getting question marks surrounded by a diamond. In an effort to get rid of them I hit the forums and after trying every utf-8 plugin I could find nothing seemed to work. So I decided to add this to my
    wp-config.php file
    define(‘DB_CHARSET’, ‘utf8’);
    define(‘DB_COLLATE’, ‘utf8_general_ci’);

    this removed all of the question mark things but now in my old posts I have all of these  once again I have tried to get rid of these by using the utf-8 plugins but nothing is working. I ahve tried to delete out

    define(‘DB_CHARSET’, ‘utf8’);
    define(‘DB_COLLATE’, ‘utf8_general_ci’);

    out of the wp-config.php but then I just get the question marks back. If anyone has any idea how to fix this please let me know.

Viewing 8 replies - 1 through 8 (of 8 total)
  • I’ve had this problem, too. Anyone know what causes it (I suspect characters brought in by copying from a word processor), and how to get rid of it?

    If there’s no easy WP based way to get rid of these characters, do you have a suggestion for directly replacing them in the MySQL database?

    Later edit: Spotted this thread, which may address some of these issues — the thread contains some links to other related threads as well:

    Thanks for the information I had already ready through that post and tried everything mentioned without any luck. I am still getting the  on my old posts

    I am guessing noone has a solution for this as of yet. I have tried everything.

    at least u got a reply, nobody knows sh1t about my problem i guess

    You are on the right track…it is an encoding issue. Your blog was probably latin1 and when you upgraded, then your wp-config.php file had utf8 as the encoding…however, that doesn’t change the db encoding. So, you now have mixed encoding in your db. There is no simple, complete, fix for this that I have found. Here is what I would suggest.

    1. If it’s not already there, put utf8 in the config file as the encoding.

    2. dump your database and keep it as a backup.

    3. Look at your database and tables and see what their encoding is…there is a good chance that you will have a mix of encoding there as well. If you see tables or the database encoded as anything other than utf8, then make a note of it…if it’s anything else, it will probably be latin1

    4. Either dump the database again, or make a copy of the one you already dumped. Open it in a text editor, and do a search and replace on any encoding that you noticed wasn’t utf8…for example, replace latin1 with utf8.

    5. Drop your tables in the database and import the corrected sql file.

    6. look at your posts and see what type of text errors you have. If you have these, Â, then do a search and replace on the dumped file, drop the tables and import again. If you have other problems, like question marks, then that’s a bit tougher because you may not want to strip out all your question marks through a search and replace, so look to see if there is a pattern that you can search for. Often, you will have / that replaces ‘ so many of your words like Steve’s will be Steve/’s. You will just have to look at what you have and use some logic to clean it up as best you can.

    If you do this, you may not be able to clean things up 100%, but all your new posts should be correct and you will have a good database if it’s set to utf8_general_ci encoding.

    Good luck.

    sounds good I will give it a try wish there was an easier fix

    Hello there. This is my first post so bear with me. I think I can help you.

    I work as a typesetter for publishers from home. Your problem is in fact very easily fixed. You have a basic font clash.

    I get funny symbols appearing in Safari when I am using particular fonts for typesetting jobs. These fonts conflict with the installed system fonts on a Mac. Same principle applies on a PC. I use a font manager and as soon as I turn off a font set that has introduced the funny symbols, restart Safari, they all disappear.

    Hope this helps.

    Commenting out the lines in wp-config.php seems to have fixed it for me:

    I got these characters after going from SQL 4.0 to 5.0 database (I used WP-DB Backup to store current database, created new 5.0 database through my host’s config system, changed the wp-config.php to use the new database, then used WP-DB Backup to restore the saved database).


Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Please help me get rid of these Â’ is closed to new replies.