WordPress.org

Forums

WooCommerce - excelling eCommerce
Please help-Fatal Error (18 posts)

  1. brendajn
    Member
    Posted 2 years ago #

    Fatal error: Call to a member function is_visible() on a non-object in /home/content/70/10788170/html/wp-content/plugins/woocommerce/templates/content-product.php on line 25

    http://wordpress.org/extend/plugins/woocommerce/

  2. Roy Ho
    Member
    Posted 2 years ago #

    Try this weird trick...Go to settings->permalinks and click on save twice and re-test...Hope it works for you...

  3. brendajn
    Member
    Posted 2 years ago #

    Thanks Splashingpixels, BUT it didn't work :(

  4. Roy Ho
    Member
    Posted 2 years ago #

    Sorry....worked for me when I had that issue....Are you using latest 2.0.5 version of WooCommerce? And if you switch to 2012 theme, do you still see the same issue?

  5. brendajn
    Member
    Posted 2 years ago #

    Yes using 2.0.5 and I have changed themes and it still comes up. I am so lost here! grrrrrrrrrr LOL

  6. Roy Ho
    Member
    Posted 2 years ago #

    Have you ever had it working?

  7. brendajn
    Member
    Posted 2 years ago #

    OK, so I deactivated WooCommerece and it went away....so any suggestions now??

  8. Roy Ho
    Member
    Posted 2 years ago #

    It goes away because the error came from the plugin. But again have you ever had it working?

  9. brendajn
    Member
    Posted 2 years ago #

    Yes i had it working last night

  10. Roy Ho
    Member
    Posted 2 years ago #

    Hmmmm what if you reactivate it, does it work now? Also what PHP version and PHP memory are you running?

  11. brendajn
    Member
    Posted 2 years ago #

    When i reactivate it it reverts back to fatal error. I am running PHP 5.3.14 33MB

  12. brendajn
    Member
    Posted 2 years ago #

    Another issue I am having and don't know how to correct it is:

    40MB - We recommend setting memory to at least 64MB.

  13. Roy Ho
    Member
    Posted 2 years ago #

    Ok 33MB is probably too little. Try increasing it to 64 or 128MB

  14. brendajn
    Member
    Posted 2 years ago #

    Can you tell me HOW to do that. Please?

  15. Roy Ho
    Member
    Posted 2 years ago #

    Ask your hosting company to do this for you.

  16. brendajn
    Member
    Posted 2 years ago #

    Ok thank you for trying to help me. New here and this might be too much for me! HAGD!

  17. Roy Ho
    Member
    Posted 2 years ago #

    You can also try this... edit your wp-config.php and add in the following line:

    define('WP_MEMORY_LIMIT', '64M');

    This may or may not work depending on your hosting. So if it doesn't, you need to ask your host to do it in the php.ini level.

  18. Marsc
    Member
    Posted 1 year ago #

    Well?

    Thanks for nothing OP.

    The OP's error wasn't the memory problem and he didn't post the solution.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WooCommerce - excelling eCommerce
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.